How do I get pdf extension to be added

Importing documents using ScanSnap S1300i, it creates PDFs in the Inbox; However it does not put the .pdf extension on the filename. How can I have it automatically apply the extension?

This would either be the ScanSnap software or this setting…

Thank you for your suggestion, I changed the setting from “filename with extension” to “localized display name”. Unfortunately that did not make any difference. I have also checked the ScsnSnap manager settings and they imply that the .pdf extension should applied to the file name. Could there be something in the interface between ScanSnap and DTPO?