How do I get previous DEVONthink database into DEVONthink Pr

I recently was using a trial version of DEVONthink and upgraded to DEVONthink Pro when I decided to use it as a part of my workflow.

I installed DEVONthink Pro and created a new database wheb I opened the program for the first time but I can’t seem to get my old data to show up in the new program.

Does anyone have suggestions? Should I open the old program up (the demo license has expired) and export everything? I appreciate any suggestions you guys have for the newest of newbies.


B. Baltimore Brown

Your DEVONthink PE 2.0 database is the folder named DEVONthink at ~/Library/Application Support/.

Select that folder and move it to your Documents folder. Select the folder once more and press Command-I to open the Info panel. Rename the DEVONthink PE 2 database folder, and add the suffix “.dtBase2” (without quotes, but case is important). Close the Info panel. The DT PE 2.0 database is now a DT Pro 2 database package file.

Now open the database under DT Pro 2.0.

I did as you instructed and the file appears to be correct. However, when I open it in DEVONthink Pro it appears as an empty database.

I cannot see any of the files and such. They do exist inside the the “files” folder within the structure (I viewed the package contents to confirm this) but they’re no showing up in the program.

Any ideas?

I had assumed you were using DT Personal 2.0. There are very significant differences between the database structures of 1.x and 2.0. One obvious tipoff: in DT PE 1.x, the internal folder holding files is named “Files”; in DT PE 2.0, that folder is named “Files.noindex”.

If you had been using DT Personal 1.x previously, the renaming suffix should be “.dtBase” instead of “.dtBase2”.

That would produce a DT Pro 1.x database. When opened by DT Pro 2.0, a copy would be created as a DT Pro 2.0 database.

Note: Depending on Preferences > General settings, it’s possible to open a database with no open view window. If that happens, choose File > New Window.

Thanks for the instructions, Bill. It worked perfectly.