How do I troubleshoot sorter shortcuts not working

Monterey 12.6.2
DevonThink latest version

Take Note and Copy Selection which I like very much, are unresponsive, despite restarting DevonThink, my Mac etc

Search and Clip to DevonThink hotkeys work fine.

thanks in advance for your time and help

In which app(s) do you use these shortcuts, did you try different ones?

1 Like

chrome, safari, Scrivener

In System Preferences-> Privacy & Security, can you check that under Automation β€œDEVONthink 3” is enabled for Safari and Chrome.

Screen Capture 26 Jan 2023 at 16.52.43

and under Preferences-> Privacy & Security->Accessibility check that DEVONthink 3 is enabled.

Screen Capture 26 Jan 2023 at 17.03.25


thank you for your post.
I re-checked in System Preferences-> Privacy & Security, under Automation β€œDEVONthink 3” Safari and Chrome and Scrivener are enabled.
what I tried and did not work:

  • to uncheck and recheck those apps in sys pref automation DevonThink
  • restart DevonThink and mac
  • change DevonThink sorter shortcuts

So not even the Take Note function is working?
What other utilities with hotkeys are you running, e.g., Keyboard Maestro, BetterTouchTool, etc. ?

1 Like

no, it is not, neither is copy selection, but both search and clip to DT work.

BTT and KBM are running but the problem persists when I quit them (quit BTT and KM engine)

Shortcut detective app does not find any conflicts. Anyways, it has nothing to do with the choice of shortcuts, because I tried to modify those shortcuts in DT>PrefSorter and the problem persists.

Other clue: if I click on the sorter as per below, nothing happens. It does not open.

It is driving me bananas.

thank you for your reply


@aedwards @BLUEFROG @cgrunenberg

I searched the forum found the following post from May 2011 by Alan @aedwards

  • I don’t see a sorter quit button in Pref>Sorter.
  • may I go ahead and delete ~/Library/Preferences/com.devon-technologies.think-sorter.plist ?

thank you

sorter bugs - DEVONthink / Tips - DEVONtechnologies Community


May 2011

To stop the Sorter disappearing please try the following:

  1. Open the sorter preferences and press the quit Sorter button
  2. Delete the Sorter preferences file which can be folder at ~/Library/Preferences/com.devon-technologies.think-sorter.plist, where ~ is your home folder.
  3. Restart the sorter by pressing the start sorter button in the preferences.



This is a very old & outdated post (like most posts older than 2019), the Sorter of version 2.x is not the same as the one of version 3.x.

1 Like

I think that I have a sorter problem. Is there no way to reset the sorter ?

Does the Sorter work after switching its appearance to menu extra (see Preferences > Sorter)?

1 Like

the icon/label DevonThink appear in the menu bar, but nothing happens when I click on it. The actual sorter window does not open. Just like the dock tab.
thank you

Can you send a copy of the console log, the easiest way to do this is in DEVONthink by selecting the Help menu and whilst pressing the option key select β€œReport a Bug”. This will open an email containing the log files. If you could mark it for the attention of Alan that would be great.

OK just sent. thanks very much

Thanks for sending the logs, try the following:

Open the Terminal application, copy and paste the line below and press Return.
defaults write com.devon-technologies.think3 UCCTakeNoteRestore -bool false

The Sorter should open and work as normal now.

1 Like

works perfectly. Thank you very much Alan !

1 Like

While searching for a solution to my non-functioning Sorter, I just found this discussion. This made my day. It has been driving me crazy for quite awhile. Thanks for the help.

Are you running DEVONthink 3.9?


(Apologies for the minor threadjack, but it’s about sorter shortcuts, so it’s sort of relevant…)

Is it expected behaviour that Sorter Search is not available when it’s acting as a floating popup (i.e. Appearance = none)?

The other key shortcuts work fine, but Search doesn’t. I’ve done the normal debugging and there’s no conflict anywhere β€” and the same shortcut works when the appearance is either β€˜Dock’ or β€˜Menu’.


The other key shortcuts work fine, but Search doesn’t.

What other shortcuts ?