How to avoid problems due to permissions


I’ve been using DTPro for about 18 months now and I’ve just run into my first real problem: I discovered that about 800 files were missing from one of my DTPro databases. I was able to recover by using one of my external backups created using the Daily Backup Archive script. But I’m concerned that I don’t really know how this happened in the first place.

I’ve spent a lot of time over the previous 18 months reading and occasionally interacting on the forums, consulting the manual, and becoming more cautious about the way I run MacOS. But I’m still confused about how permissions affect DTPro databases and the files therein. I’ve always been pretty conservative with my databases, copying them “manually” or using ChronoSync to copy entire databases from one machine to a portable HDD to another machine and then back again. This has been very stable for most of my very short career of DTPro usage.

But recently, after rebuilding my system I encountered an issue that I don’t really grasp, the “ignore file ownership” option on my portable HDD. And despite their attempts to help, the tech support staff at Econ Technologies have not been able to enlighten me regarding the difference between leaving the option “ignore file ownership” checked or unchecked on my portable HDD when I run basic left-right syncs. If you leave “ignore file ownership” checked Chronosync warns you but it’s not clear to me what the risk is. If you leave “ignore file ownership” unchecked then, presumably, the permissions for the file are preserved as it is copied to another machine. Maybe this has nothing to do with my missing file issue but I want to be certain given my dependence upon this kind of “syncing” between machines.

I’ve looked for “ignore file ownership” in the forums but haven’t found anything that helps. I’d appreciate any help on this issue.


By enabling “Ignore ownership on this volume” all users can access the files/folders on the volume. However, the recommended solution to sync databases between two machines right now is to copy the complete & closed database from one computer to the other. Modifying databases on two computers concurrently and trying to sync them later using e.g. ChronoSync will probably fail.

However, we’re working on synchronization of databases/computers via LAN/WLAN/WebDAV/Dropbox and MobileMe/iCloud. This will be available later this year (hopefully later this summer).

Yes, this is exactly what I’ve been doing. So, leaving this option checked and copying complete and closed databases is the recommended approach?

That’s great news, thanks.


I’m having the same troubles as others with file permissions: when I try to copy my Devonthink databases (e.g. to back them up) using Finder, I get a series of file permission errors. Even when I click “Ignore” on these errors, eventually Finder gives up and stops copying the files altogether.

Here’s the folder I’m copying, “DevonThink.”

So I read this forum post, and did some Googling around. I found this helpful post but there isn’t an “Ignore ownership on this volume” checkbox at the bottom of my Info pane:

And there isn’t a checkbox at the bottom of my hard drive’s Info pane, FWIW.

Any suggestions?


I’m just following up on my original post, in case there’s been any progress since I wrote it.

For instance, is there a way to search a database for files that have restricted permissions? Or even a way to do this in Finder?

Surely this is a simple matter of finding the problematic files, and either changing their permissions or deleting them.