How to change text size automatically after import?

When I write text in Nisus, my favorite word processor, I usually do it in 12p and have the page zoomed 200%. Now, when I import such files into DEVONthink, the 12p is retained, but there is no zoom feature in DEVONthink, as far as I know. The result is, the text is too small for my old eyes, and I have to adjust it manually to 16p .

Now I’m wondering if this can be automized, for example with a smart rule.

In order for this to work I need to automatically select the text first. Similarly, when the size has been set to 16p I want to deselect the text.

-- Script Format > Body Normal
-- Created by Christian Grunenberg on Sat May 15 2004.
-- Copyright (c) 2004-2014. All rights reserved.

tell application id "DNtp"
		tell selected text of think window 1
			set properties to {alignment:justified, font:"Times", size:16, color:{5000, 5000, 5000}, background:{65535, 65535, 65535}}
		end tell
	end try
end tell
  1. How can I replace the pseudo-code (‘SELECT ALL’ and ‘DESELECT ALL’) with correct AppleScript commands in the script above?

  2. I’m also not sure whether the first part of the AppleScript “on performSmartRule(theRecords)” should be included at all. Should I delete it from the script?

  3. How can I change the AppleScript above so that it will automatically change the text size in ALL rich text files in all (open) databases?

If someone has a better approach, then please share it with me. I’m open for everything, as long as it automates the size change.

Unless you have a need to actually change the point size, I wouldn’t pursue using a smart rule to affect the change. You certainly can magnify the view/edit pane when viewing rich text files. See View > Zoom. Additionally, when you magnify a rich text file in DEVONthink, it not only doesn’t affect the actual content, it maintains that magnification for rich text files you subsequently view.

That definitely solves my problem. Thank you.

… But, alas, now I have another problem. I notice now some new strange behavior (after having tried to use AppleScript): all RTF I now import from Finder end up being locked in DT, and I seem not to be able to unlock them so that I can edit them in DEVONthink.


I tried to convert the imported rich text files to Rich Text, and that opened them for editing. Strange… I convert Rich Text to Rich Text and that obviously changes the file somehow.


This is the first time I have experienced this.

RTF documents created by Nisus Writer are marked as read-only to avoid loss of proprietary extensions added by Nisus Writer which are not supported by macOS’ text engine.