How to create a shortcut to Convert to PDF (One Page)?

Hi, I can (and did) create shortcuts to some of my favorite commands (in dialog Apple System Prefs / Keyboard / Shortcuts / App Shortcuts / DEVONthink BUT,

can’t seem to be able to do it for the create PDF. I tried assigning (F7) to:

“to PDF (One Page)” - which is exactly the menu item name - NOPE.
“Convert to PDF (One Page)” (just for the sake of it…_ - NADA.

How is it done?


Does it work using another shortcut? Maybe F7 is already used by the system or another app or menu item.

Assigning keys without keyboard modifiers is rarely a good idea. Add a Command or Option key to the assignment and see how it works.

Nope, no other F key works, I mean, the ones not taken. I even broke some previous associations just to check.

Jim, these are F keys at top… I’ve always been able to use them with any other script, including DT

As an alternative (I know, out of laziness) I could add a script to the DT toolbar.

is there a script somewhere to convert a file to pdf? I tried searching but couldn’t find a more recent one (other than this Scripting "Capture PDF" context menu option)

I understand that but I stand by my previous comment. It’s always a good idea to add a modifier key to a shortcut.

Did you try the suggestion, e.g., Option-F7, noting Command-F7 is already in use by DEVONthink?

Jim, you’re right - Command-F7 worked. And I get your comment - but why is it so?


Command-F7 worked.

Actually I suggest you use Option-F7.
Command-F7 used by DEVONthink for View > Full Screen > Document.

And I get your comment - but why is it so?

It’s a safer option to use, i.e., avoiding clashes with preset use of the keys. This is the same thought process that keeps us from assigning letters or numbers alone. Imagine typing a sentence when you’ve bound a script to the letter “e”! :open_mouth:


More seriously - thanks! I ended up using Command-F9, working fine right now.

You’re welcome :slight_smile: