How to free CMD-CTRL-I for user use?

Hello. After a recent upgrade, an AppleScript script I’ve used for years—to paste a timestamp from VLC—stopped working because DTP no longer recognized the shortcut. The script filename was


… and the shortcut was obviously CMD-CTRL-I.

So that means that CMD-CTRL-I is assigned to something in the new DTP, right? Well, I tried finding it two months ago but gave up and have been using the Scripts menu instead. But I need speed again so that idiotic solution will no longer work.

I know I can use System Preferences to free-up the shortcut by entering the DTP command name (in its menu bar hierarchy) and assigning a garbage string instead. This will then release CMD-CTRL-I for user use.

But for the life of me I cannot find what the command is—nothing in the menu bar blinks when I press the shortcut!

How would you solve a puzzle like this?

Not necessarily. You might want to search for Logitech here to find reports of similar problems.

I’m not sure that’s true; on my mac that key combination is not apparently recognised - in DT it just throws a system sound; testing other (bizarre) combinations suggests that is what happens when the combination is not linked to any action. Software is available to detect to which application a keyboard shortcut is directed (Shortcut Detective has been previously mentioned in this forum, although I have no personal experience).

I have tested that key combination using both KeyCue and ShortCut Detective. The combination is not used by DT3. Nor anything else on my system that I have tested thus far.

1 Like

I’d see if the script runs from Script Editor.

Someone else mentioned using KeyCue to check that the culprit is not DEVONthink, but I want to suggest using KeyCue to help figure out what is using that shortcut. It’s my go-to solution to figuring out what keys are assigned and to what, and may help in your case.

ShortcutDetective would be a lot quicker – and it is free. You can find it a little way down the page here.

If you have never used it, it merely requires launching the program, then typing the shortcut/hotkey while the program window is at the front. The program will then tell you which application is using that shortcut.

Using KeyCue would potentially mean launching one program after another until you find the culprit.

1 Like

It works. I assigned CMD-CTRL-H and that runs it. I downloaded KeyCue and in its massive, comprehensive table of assignments, CMD-CTRL-I is nowhere to be found.

I rotated through all running apps and long-pressed CMD-CTRL in each to bring up KeyCue. None of them had CMD-CTRL-I assigned.

Hmmm. Would you mind assigning CMD-CTRL-I to a simple script and seeing if it runs? I just installed DTP on another Mac and tried it there and it also does not work!

So it works neither on MBP 16" 2021 Monterrey nor on MBP 15" 2015 Catalina.

Just to check - is that a small L or a capital i? If it is a capital i, just for fun, try using a small i in the script name. Maybe one of the folk can try it out for you, I am desperately pushed for time. If nobody has responded by tomorrow, I will try and fit it in.

It may be worth trying ShortcutDetective; per @mbbntu’s comment, it seems it doesn’t require switching to different applications to find shortcuts.

That’s a capital i (eye).

I just tried lowercase and that didn’t help.

Just did. I don’t think it works on Monterey. It just gives me the spinning timer, the word “Detecting …”, and the latest key combo I pressed. None are ever recognized. E.g., CMD-H, CMD-N, etc.