How to make a direct connection with DT2Go 2?

I want a direct connection between my iMac and my iPod Touch using DEVONthink Personal and DEVONthink to Go 2. All OS and app software is current. I set the Bonjour options on my iMac. I select both “Enable incoming connections” and “Open databases automatically”. I let the computer choose the port. I enter a password. I click “OK”. The information is saved.

Then I go to my IPod Touch. I edit locations. The IPod finds the iMac. I select the iMac. After I press “Done”, the row showing the iMac location becomes dim. The next time I press the settings button on DT2Go, I see a spinning wheel next to “Edit locations”. The wheel never stops.

I cannot find any way to initiate a sync. I am never asked for the Bonjour password on my iPod.
In most attempts, there is no indication of a sync. Once, the sync indicator spun for a while in the upper left corner of my iPod. I don’t know what was different about that attempt. After it stopped, I could not find any files that had been sync’d.

On my iMac, I cannot find a way to add my database to the list of databases in the Preferences - Sync tab to be sync’d.

I understand that Bonjour options have to be set on only one device. Since the sync is not working when I set Bonjour options on my iMac, I turn them off and try to set them on my iPod instead. But I cannot because all Bonjour options remain dim/disable.

“File” - “Synchronize” is never enabled on my iMac.

What am I missing?

Please start a Support Ticket. Thanks.

Do you have a database open on your Mac?


I’m having the same problem and I have opened a ticket referencing this thread.

I am also seeing the same problem.

It was working fine during the DT2Go beta but since upgrading DT to 2.9 and DT2Go to the released version things have stopped working.

@harrinp1: Make sure you delete the plugins in ~/Library/Application Support/DEVONthink Pro 2/Plugins after restarting DEVONthink.

Tried that but still not getting that syncing feeling…

Please start a Support Ticket. Thanks.

Solution: allow DEVONthink on iMac to accept incoming connections through the firewall. Thanks to Jim N. for his help.

My pleasure. Happy Syncing. :smiley: