How to make files with the ending ".md" have the kind "Markdown Text"

Imported files with an .md extension are correctly detected as files to be displayed as Markdown documents - so far so good.

However in the Kind column they show up as “md”. Markdown documents created in DEVONthink itself get the extension .markdown and they show up as “Markdown Text”.

How can I tell DEVONthink to display md files as “Markdown Text” as well?

You could use a style sheet to display them as HTML or so.

Any text can be markdown therefore, it does not matter how the extension is called. You can also change it as at the end of the day it remains a text doc.

Hope that helps
Steffi

I’m not seeing any issue here.
What is shown in the Info inspector?

Did you create them on the Mac? In that case the extension should be always .md

Mmmmmh, I just tried it: New Markdown files created on DT3 receive kind md, but old files (probably created either with DT2 or DTTG) show up with kind Markdown Text.

Any way to consolidate this into one kind?

Batch processing (see Tools menu) is one possibility, e.g. select a bunch of Markdown files with the wrong extension and perform this action:

Thanks for this @cgrunenberg!

Does it mean the file extension defines the type?

So when I change all .markdown files to .md files they all should have the same kind md?

Also, what happens when I batch-change Indexed Items in the regular filesystem? Or should I change them better on the file system?

Yes, the extension defines the type. But only plain text documents (including Markdown) support such changes.

This changes the file extension in the Finder. Just try it using an indexed dummy file.

Also, what happens when I batch-change Indexed Items in the regular filesystem? Or should I change them better on the file system?

What is “the regular filesystem”?

PS: You should not get into the internals of a database and make changes there. If you were indexing the files, it wouldn’t matter as they’re external to the database.

Sorry for the confusion. With “regular filesystem” I mean documents which are external to DEVONthink, sitting “regularly” on the filesystem (I used regular to distinguish these files from files internal in the DEVONthink database.

@cgrunenberg’s suggestion of the batch change seems to work so far well. :smile:

I haven’t done my bulk change to md yet, but things get stranger @cgrunenberg: The kind has changed in the kind column - without a modification of the documents! How is this possible?

Here a screenshot of a group with two test documents from a few days ago just after creation of the documents in DT3:

And here the same group with the same documents today:

The extension is still the same: .md. I have the suspicion the syncing with DTTG must have changed things. Any ideas?

Did you edit any of the files with DEVONthink To Go?

Not to my knowledge.

I did keep DTTG open overnight though. (I do this when I charge the iPad overnight to be sure everything is synced in the morning.)

And the extensions are still .md!!!

Hold the Option key and choose Help > Report bug to start a support ticket.

Done. :slight_smile: