How to move database from DT to DT Pro?

Sorry if this is a newbie question with an obvious answer, but I can’t seem to find what I’m looking for in the help documents…

I am in the trial version of DT and have created a database. So far, so good. Now I want to try DT Pro, but can’t figure out how to import (or move? or copy?) the DT database so it’s accessible by DT Pro?

Any suggestions what to do or where to look for the answer? Thanks a lot!

Have you experimented a bit? Since I’m using DTPO2 I can’t really downgrade to set up my own experiments but I’d hazard a guess that downloading the demo version of Pro or Pro Office, then launching it might work. Open it with File > Open Database (then navigate to your DT Personal DB that you’ve previously created) and see if DTP or DTPO opens it. If the DB that you’ve already created has critical stuff in it, make a backup copy just in case.

I’m near-certain DTech staff has stated (multiple times) that v2 DT Personal databases are upward compatible with DT Pro (Office).

Here’s what I’ve tried so far…

  1. I created a sample database in DT-Personal and it works fine. I included lots of .rtfd imported files, plus a few new documents, too. I have some groups in the Inbox, others located at the main level of the tree.

The original DT-Personal db is in ~/Library/Application Support/DEVONthink 2 (at least that’s what it says when I view File>> Database Properties…)

  1. In DT-Pro I tried finding the DT-Personal db with File>>Open. However, all files I could find in the above directory (ending in .dtMeta) were grayed out. I sort of think there should be a file ending in .dtbase2, but I can’t find it. Is there another filename I should look for or is it in another directory?

  2. I also tried the same thing with File>>Import… same result.

  3. In DT-Pro I tried the above steps both before and after creating a new empty database. Seems that doesn’t matter, either.

Is there a script in DT-Pro I need to use? Both my DT-Personal and DT-Pro are demo copies. Perhaps there’s a limitation in the demo versions?

Thanks again for any help!

v2 Pro (Office) databases have .dtBase2 extensions; not sure about Personal. I’d expect v2 Pro (Office) to be able to directly open one that’s created in v2 Personal.

Do you have both Personal and Pro installed? Best if only one version is installed at a time, e.g. so Services will work properly. If Personal is uninstalled then I’d think its database would automatically open with Pro, though I could be wrong.

Can you open the ~/Library/Application Support/DEVONthink 2 folder directly in Finder? If it contains .dtMeta files then that folder is the database, but that doesn’t make sense to me. I’d expect to find a .dtBase2 db package instead that folder, double-clicking it would open it either in Personal or Pro, and you’d have to use “Show Package Contents” in Finder to poke around inside it.

Sorry if that’s not helpful beyond what you’ve already found and know.

Thanks for trying to help.

I am running both versions on my machine, and in fact, both seem to work just fine separately… I can add information to each, and they both seem to save the information OK and open it up fine with no data loss or confusion. It’s only when I try to look for and open the DT-Personal db with the DT-Pro that things don’t work.

(I haven’t tried Services, though… You might be right that my Mac might get confused which one to open up. Later on, I will choose only a single app to purchase and keep.)

For DT-Personal:
In my Application Support>>DEVONthink 2 directory, I can find no .dtbase2 file at all. There are 10 “DEVONthink-x.dtMeta” files, a “Backup” directory (duplicating the Meta files), a directory called “Files.noindex” which contains subdirectories for .rtf and .rtfd files (from my imported .rtfds, I presume), a “Plugins” directory (empty), a “Settings.plist” file, and a “Templates.noindex” directory (also empty). There is nothing else there. No .dtbase2 file.

For DT-Pro:
There is a separate folder in Application Support called “DEVONthink Pro 2” in which there is a file called “Inbox.dtbase2”. (Created during installation, I imagine.) There is also a file called “Inbox”, directories called “Plugins”, “Scripts” and “Templates.noindex” and a file called “SmartGroups.plist”.

One thing to note, after I got it DT-Personal up and running I set the “DEVONthink 2” directory as an alias to another drive partition I have, so all my files were off my main hard drive. It doesn’t seem to affect the database… everything saves and opens OK, and appears to mirror what I originally had in my ~/Library/Application Support directory. In other words, pointing to an alias rather than a real “DEVONthink 2” directory doesn’t seem to affect the running of the database. But I wonder if doing so somehow “hid” the .dtbase2 file? Still, a search reveals nothing.

(And yes, I did switch back to real files and not an alias, and it’s the same result.)

(And yes, I did turn off password protect which I had originally set, and it’s the same result. And yes, I did use the terminal to look for invisible files, and there weren’t any.)

In short, it’s a mystery. Where is the missing .dtbase2 file supposedly created by DT-Personal which I would obviously use if I wanted to open it up in DT-Pro?

Any other detectives out there? Thanks for your help!

That’s a strange place to find it but since I haven’t used Personal in quite a while, I can’t say one way or the other if that’s the right place for it. When you created the database and saved it, did you get a dialog box that let you determine where to save it? I usually save my DBs in my Documents folder.

To expand on the “Show Package Contents,” you do this by right- (or control-) clicking the icon. This will show you what the file contains.

Anyway, first, make sure that you’re only running DTPO and not DT Personal concurrently. Then try to open the DT Personal DB by going to File > Open > [navigate to it in the application support folder] and see if that works. If it’s a true DT 2 database, you’ll see files such as DEVONthink-1.dtMeta, a folder called Files.noindex, which will contain folders of different types of files (such as pdf, webarchive, etc.).

Here’s another thing you might try: Create a Finder Smart Folder by searching for Kind is Other [DEVON database] and see if there is somehow a duplicate file or other weird stuff showing up. Just a shot in the dark.

We’re all suggesting different things here because basically Personal databases ought to open in Pro or Pro Office and if yours doesn’t, forgive us if we feeel that it’s an unusual case. Last resort: Open a support ticket and include the offending database as an attached file along with any log files.

  1. Copy the DT Personal 2 database to your Documents folder. Your DT Personal 2.0 database is the folder named ‘DEVONthink 2’ at /Home/Library/Application Support/. NOTE: Quit DT Personal before making the copy.

  2. Select the copied DT Personal 2 database and press Command-I to open the Info panel. Rename the database by adding the suffix ‘.dtBase2’.

  3. Launch DT Pro 2, press File > Open Databases and choose File > Open Database, then select your newly renamed database.

Bingo! That was the problem… For some reason, what was supposed to be my database file became a folder. By adding the .dtbase2 suffix DT-Pro was able to recognise it! Yaay!

Thus, a DT database is a package not a file. Now I understand those comments here referring to “Show Package Contents…” In fact, with my original problem I had no package at all, and couldn’t understand what those folks were talking about. Now that I DO have a package, I can see what they meant.

I truly don’t know what I did in the first place to get this problem. I know, though, that I did NOT manually remove the suffix from my db. I tend to play around a lot, though, to customise any new app, so I might have accidentally made a change somewhere I shouldn’t have or at the wrong time. Sorry I can’t be of more help to the DT people who might wish to try to head off this issue in the future.

Thanks to all who pitched in to solve this little mystery! Great response in this forum, I must say!

Glad you were able to resolve it and learn a few new things along the way. :slight_smile:

Just to clarify, a DEVONthink Personal database is a folder, not a package file. DEVONthink Pro/Pro Office databases are package files.

There are major structural differences between DEVONthink 1.x and DEVONthink 2.0 databases.

To convert a DT Personal 1.x database to the Pro/Office 1.x package format, rename the folder by adding the suffix ‘.dtBase’. Now the database can be opened by DT Pro/Office 1.x, or read and converted a to DT Pro/Office 2.0 by opening the 1.x Pro database with DT Pro/Office 2.0.

To convert a DT Personal 2.0 database folder to a DT Pro/Office 2.0 database, rename the Personal 2.0 database folder by adding the suffix ‘.dtBase2’.

Why has this question not been answered satisfactorily yet? I am going through the same problem. I want to tryout the Pro Office (upgrade from Personal 2), but the Pro Office is not bringing up the database I have created in the Personal. I followed all the steps mentioned in this forum already