How to set up a direct connection for sync?


I have v2.8.8 DEVONthink Pro Office on my mac and DEVONthink To Go v 2.0.2 (15979) on my iPhone.

I used to have older version of the iPhone app and was successfully sync’ing with my mac directly. I still have older iPad version of the to go app and that still sync’s ok with my mac.

I’m really struggling to understand how to setup a direct connection in the new iPhone to go app. Can someone help?

If I go to edit locations I just see:

New Box Account
New CloudMe Account
New Dropbox Account
New WebDAV Server

Am I meant to see something here for a direct connection to mac?

I’ve rebooted mac and iphone and router but still nothing and my iPhone and Mac are on the same WiFi network (as is my iPad which syncs ok on older app).


The Help file could be more explicit about this, but what you want to do is configure Bonjour options in DEVONthink > Preferences > Sync

once you have this configured, then the Sync preferences should show

On your iPhone or iPad, in Settings, press “Edit Locations” and you should see an option that shows your computer name and “local network”. Add that connection, choose the database(s) you want to sync. You can only choose a single database at a time, wait for it to sync, then choose another if you wish. While local sync is occurring, DEVONthink on the desktop needs to be open. On the desktop, the app’s Activity window will show a progress bar.

OK I tried that, my screen looks a bit different so not sure if done properly (see attached)?

After doing that I couldn’t see anything on the iPhone app under edit locations about a direct connection. I quit both desktop and iPhone app and checked on same WiFi network but still not seeing anything.

I’m travelling tomorrow so really hoping I can sync as it has a lot of docs I need to take with me!

Appreciate any more help.

You’re using an outdated version of DEVONthink Pro Office. Upgrade to DEVONthink Pro Office 2.9.4. Make sure you also have the current version of DEVONthink to Go on your iOS device(s).

Thanks for your help. I had done ‘check for updates’ in the desktop app previously so assumed i had the latest version, but didn’t realise I needed to re-download the desktop app again.

I have to say that I find the help documentation not very user friendly. I’d spent quite a bit of time trying to get things working before coming here.

Anyway done now.

Now I just need to find a way to scan japanese documents and have them translated to english and I’ll be super happy!