How to turn off keyboard shortcuts

I had set up ^-Opt-Cmd O for my own global keyboard shortcut in system preferences.

After installing Devon Agent, that shortcut now seems to trigger something in DA. How do I turn this off?


DEVONagent doesn’t use global shortcuts (and this shortcut doesn’t do anything over here in DEVONagent). You might check the scripts menu - maybe there’s an old script using this combination.

Could it be DT-Pro that installs it as a shortcut to DA? I see a similar issue, and have DT-Pro.


DEVONthink Pro doesn’t use global shortcuts either (except the Sorter). Which version are you using?

I have DA 2.3.1 and DTPO 2.0pb4.

I may have located the problem. Does DA offer a service “Open URL”? If so, it conflicts with the “Open URL” service built into 10.5.6. Because keyboard shortcuts via System Preferences in OSX seem to use the Service name, perhaps the DA service name should be changed to avoid diverting a keyboard shortcut intended for OSX’s “Open URL”?

Fyi, many of the DT-Pro services on my services menu seem to have keyboard shortcuts associated with them (show up on the menu), and I know I did not set these.

DEVONagent provides a “Open URL” service but services define their shortcuts on their own (and can’t use the Control modifier key), not via system preferences. And I’ve just set the standard shortcuts in system preferences but can’t spot anything using Cmd-Ctrl-Opt-O.

Here is how I think it happened:

  • OSX defines “Open URL” service
  • User defines keyboard shortcut “^-Opt-Cmd O” to “Open URL”
  • OSX looks up shortcut by service name
  • Shorcut works fine
  • DT defines “Open URL” service
  • OSX looks up shortcut by service name
  • Shortcut now breaks (calls DT service instead)