iCloud Drive DT3 Sync Location

Can anyone tell me where DT3 database is stored within iCloud Drive. I would like to share this file with my wife so that she can sync her copy/seat of DEVONthink with mine. We have a shared iCloud account but her’s does not seem to sync properly. I realize this may be considered not the best approach. I have tried to setup WebDav on a Synology but was unsuccessful…Thx

As has been discussed many times, there is not a copy of a DEVONthink database in any sync location.

Also, you should not and cannot put a DEVONthink database in any cloud-synced folder or you could irreparably damage it.

We have a shared iCloud account

Meaning you’re both logging in with the same Apple ID?

Are you often changing the database and needing to share frequent updates? If not, then why use a remote sync option?
You could use a Bonjour sync on your local network and the devices would sync when they’re both on and running DEVONthink.

There is a forum post on syncing: Sync Types Explained. This is a good place to start.
There is also one specifically about Bonjour: Bonjour Simplified

DEVONthink is not stored on the iCloud sync location. Databases are stored locally and iCloud (or other sync method) only holds data used exclusively by DEVONthink to sync.

You are apparently running into the unreliability of Apple’s iCloud for synching. Discussed t length here and experienced by others. Or perhaps you are using different Apple ID’s. Hard to tell from here.

You don’t say what went wrong with Synology WebDav setup. Works fine here, but it is a more complicated setup than other methods. There are threads here with good advice how to setup. I recommend you search.

Also consider using Bonjour which is the quickest and most reliable sync method. Turn “on” Bonjour on your machine and then setup your wife’s machine to connect and sync.

See the DEVONthink Manual for more elaboration on above, and supplementary info at:


I have used Bonjour and have issues with it. Even though DT3 is running on all Mac’s it does not reliably sync over my wireless mesh router. I would also like to be able to work remotely with DT3 and be able to sync.

WebDav would be ideal but I spent hours trying to get it to work on my Synology. I read all the info mentioned in above replies but still had issues setting this up. I have searched this forum & the internet on Synology Webdav/Devonthink setup guide and have not found anything that helped me.

Having no problems here with Bonjour and my network is wireless mesh (eero). I can’t think of any reason a mesh network is the root cause of Bonjour networking not working, but only you know symptoms.

Nothing says you have to use one sync method. If Apple’s iCloud is working for you, keep using it in addition to Bonjour and/or WebDAV (after making one or both work).

I have Bonjour, Synology NAS, and Dropbox working, all fine no issues, for five macOS and iOS devices.

I re-read page 68 of the DEVONthink Manual (3.9.2 version) and it is far as I can tell complete instructions for WebDAV. These are the instructions I used a very long time ago to setup my Synology NAS. I didn’t need any supplementary information/guidance from here, as I recall.

Good luck.

I would also like to be able to work remotely with DT3 and be able to sync.

To be clear, you are not working remotely, e.g., you are not accessing the databases on another device. Each device has its own copy of the database with local data.

Also, this does not necessitate using a remote sync option unless you are using a shallow sync, i.e., Download Files: On demand in DEVONthink To Go.

Thanks, I will give it another go!

I suggest you retry Bonjour first. Simpler than WebDAV.

I think my Bonjour problem is related to the fact that the main/wan mesh router is IP: ???.???.100.1 whereas the other routers are ???.???.103.249 and ???.???.103.250. Any thoughts on this would be appreciated…Thx

I think you are correct.

There are others here who are more expert than me on networking. What you report above seems troublesome to me. All devices, should, far as I know and have always done, have been in one range. There are technical names for these networking “ranges”, but it’s been years since I had to know all that stuff :wink:.
My internal network behind the ISP router, run by an eero box has DHCP assigning IPs always as 192.168.4.x, with “x” being from 100 to 255. I reserve address for X < 100 to be for fixed IP’s like the NAS, and a few other boxes. I probably don’t need fixed IPs, but I have them and I’m not changing. 1 is the gateway to the Internet. Have almost 250 devices thus available is well more than enough. If I had more than that, I’d have to crack open my old networking text books to decide how to re-design the network.

The IP address of the router isn’t going to be the same as the IP addresses it serves to devices on the network, i.e., the public IP of your router – the connection to the outside world – will not be the same as the internal addresses.

However, I don’t use mesh routers so someone can correct me on that specifically, if needed.

1 Like

Bonjour is (like DHCP) a zero-conf protocol that can’t work across network boundaries. Why not put all your devices in the same network?

And there is a guide on WebDAV with Synology here:


I have been looking for a way to do this with my TP-Link Deco x55 mesh router. I agree that the different IP’s are the issue with Bonjour.

Yes, I think if all of my Mesh routers used the 192.168.100.x range Bonjour would work properly and without issue. I am going to try to figure out how to assign static IP’S to each Mesh unit…Thx

I’m not sure on the setup but you may want to look for DHCP Reservations in the router’s setup. Also, I’m not sure if your satellite units are also handing out IP addresses. Logically it seems like they shouldn’t be.

1 Like

If you have NAT from your ISP (which you almost certainly do), and you install a mesh router connected to the box you got from your ISP, you’ll probably get double NAT on IPv4. The solution is usually to find the setting that puts your mesh system into bridged mode, that’s what I did with my Linksys mesh setup. That makes the mesh system leave it up to the ISP router to handle NAT, and not handle NAT itself. You still end up with RFC1918 addresses (e.g. 10.x.y.z), but all on the same subnet, so Bonjour works. The downside is you’re now reliant on the ISP’s box to handle things like DHCP.

1 Like