iCloud Sync - Invalid key

Hi all,

Great to see iCloud sync added to 2.10 and “Go”, however, irrespective of what I enter as an encryption key, I get a message saying that it is invalid.

On my Macs (I have 2), all databases in the sync preference panel (under the iCloud tab) show as “Not yet synchronised, upload database”.

Is this something I need to do manually, or does it mean the database needs to live on iCloud now, and it is uploading?

I have deleted all other sync set-ups from before, and tried to start again, but getting nowhere.

Any help greatly appreciated.

Did you create a sync location without an encryption key then try to add one afterwards?

I have the same issue.

I previously used dropbox sync between Mac & iPhone, which I disabled before trying to set up the iCloud syncing.

On the Mac when I have selected the iCloud sync checkbox and then filled in the encryption password, the databases box populates with all my databases. However, the log window pops up with the same “Invalid encryption key.” error.

If I select on of the databases to sync I get another error “Property list invalid.”

Im pretty sure I didn’t create a sync location without a key at any stage.

To check or verify the encryption key, on the Mac…

  1. Do a Spotlight search for Keychain and open the Keychain Access application.
  2. In the logins section on the left, look for a key named DEVONcloudy Encryption (name of service) like DEVONcloudy Encryption (Dropbox).
  3. Double-click it and check the Show password checkbox. You will be required to enter your Administrative password. (This is the password you use to log into your machine with.)
  4. Press Allow (or Always Allow, if desired) and the password will be shown.
  5. Take note of the password, then quit Keychain Access.
1 Like

I seem to have already solved this by using the “Clean Database” option from within sync settings.

Thanks for the detailed information though.

That was my next suggestion. :smiley:

The iCloud Sync is completely screwed up.

I started with one iCloud sync on my office computer w/o using encryption. I assumed I could add it later. On my home laptop I added encryption. They do not seem to see one another. I see no way to add encryption to an existing sync setting.

… then I tried deleting the setup on my office computer. When I subsequently try to add an iCloud account it now adds 2 of them!

Yikes. How can I get out of this quagmire and start from scratch?

… needless to say this offers great promise but is currently more tricky to set up than previous syncs with iCloud Drive and Dropbox.

You could never add an encryption key after the fact, unless you cleaned the location first. This is not new behavior.

Setting up iCloud sync is the easiest option by far. You activate it and optionally specify an encryption key for the location. Then checkboxes for the databases you want to sync.
You are reporting abnormal behavior. Delete the extra iCloud location (and we will be looking into why this may occur) and relaunch DEVONthink.

I deleted the iCloud database. Then added without encryption.

Now I get this message: 12:25:36: iCloud Can’t create database folder, path exists already.

What is the recommended next step?

See “Can’t create database folder, path exists already”