Import by the Services Menu

I am a new member of this forum.
I recently upgraded to DT Pro 1.1.1 . I can not import text (or anything else) via the services menu. When I do Sevices/Devonthink Pro/Take Rich Note, nothing happens. I have tried logging out and logging back in as suggested in the tutorial. No luck.
I can import files using File/Import/Files and Folders.
:frowning:

I assume you do have DT Pro installed in your Applications folder, which is a requirement for Services to work.

Some applications, including (as I recall) Firefox and Camino are not Cocoa apps and can’t make much use of OS X Services. And of course some applications such as MS Word are totally unaware of Services.

But if you are using Safari and have selected text and/or images on the web page, the DT Pro/Take rich note Service should work (of course, nothing will happen if no text or image is selected).

If you’ve tried that in Safari and still have no luck, restart the computer, then try again.

Bill,

Thanks. Yes, I do have DT Pro installed in the applications folder. Also I first encountered the problem when trying to import selected text while in Safari. I’ve since tried the same thing from a few other programs with the same result.

This is strange. (by the way I am running on an Powerbook G4 under system 10.4.5.) Import file /folder works and the context menus work when I open the website in a DT pro window.

Any other thoughts appreciated.

Tmonster, yesterday I had exactly the same problem with Flock. I can’t use the Services with this browser (yes, it’s in my Applications folder). I’m afraid there’s nothing I can do. Imploring the developers is my only option :unamused:

As Flock is based on Firefox, it does probably not support services at all.

Did you upgrade to Pro from the personal edition and not delete the latter? If memory serves, I recall having some Services spookiness with two different flavors of DT in the Applications folder.

Thanks, tvillemw. That’s something I should have remembered. :slight_smile:

The “spookiness” of having both DT Pro and DT Personal Edition in the Applications folder is mostly limited to a “capture” of the keyboard shortcuts for Services by DT PE. In that case using the keyboard shortcut with the expectation that content will be sent to DT Pro will fail, as Services thinks it’s being instructed to send the material to DT PE. Because of such ambiguities we recommend that the DT PE database be converted to a DT Pro database and then DT PE should be deleted or removed from the Applications folder.

People have all sorts of preferences for using one browser or the other. Some “snap” a web page to the screen more quickly than others, for example.

But if your interest is really speed and flexibility in capturing information from the Web to DT Pro, your browser of choice will probably end up being DEVONagent, Safari or the built-in browser of DT Pro.

Safari has a keyboard shortcut (“Command-)”) to save selected text/images to DT Pro, and there are scripts in the global scripts menu to save a page either as HTML or a Web Archive. (That keyboard shortcut is also available in the DEVONagent and DT Pro browsers, but I find the contextual menu options of the latter two browsers quicker and more convenient.)

DEVONagent and DT Pro’s browser have contextual menu options to save selected material as rich text, or to save the page as HTML or a Web Archive.

DT Pro’s browser has some limitations. It can’t download a file from VersionTracker, for example, or handle some Java code. In that case, just click in the address to transfer the page to the default browser (in my case, DEVONagent).

I’ve got in my DT Pro database a large collection of bookmarks to sites that I often visit, such as scientific journals. I do most of my captures of Web material in the DT Pro browser. The sites that I routinely visit (scientific journals, news sites, governmental agencies) use pretty straightforward page designs (no fancy stuff that DT Pro’s browser can’t handle). Your experience may vary.

I do most of my Web captures as rich text that contains only the text/images that I want in my database. That lets me avoid extraneous material (ads, etc.), but also captures the material – including images – in a format that’s permanent and allows off-line viewing of images.

What do you mean by (“Command-)”)? I don’t know this keyboard shortcut.

Command-) or Shift-Command-0 is the keyboard shortcut for capturing selected text as a rich text note – a DEVONthink Pro Services option.

:question:
It doesn’t work on my Power Mac. Command is, in English, the little apple, right? (I can’t type this character, I get a question mark instead.)

Right. The Command key is an Apple keyboard feature.

I’m guessing that you’re either using a non-Apple keyboard or have changed the key configuration of an Apple keyboard.

I do have an Apple keyboard :frowning:
Whenever I type this keyboard shortcut, I get a DING DING error sound :confused:
The question is, why???

Re: preferences for using a browser or another.

I’m testing OmniWeb 5.5b1 and I’m impressed by its speed!
It’s based on WebKit (slightly modified), I think this wasn’t the case with the previous incarnations of the Omnigroup’s browser. You’ll find the release notes here.

Take a look at the Services options for DT Pro. If you have selected text in a Cocoa, one available option should be “Take Rich Note”. If the keyboard equivalent is available, you should also see it to the right of the “Take Rich Note” text.

But if the shortcut isn’t available you will get the error sound.

Why isn’t it available on some computers?

[1] The application must be in the Applications folder for Services to work.

[2] Services are not available for newly installed applications until one has performed a logout/login or reboot.

[3] Another application (perhaps DT Personal) may have “grabbed” the keyboard shortcut so that it isn’t available to DT Pro. If the culprit is DT PE, delete it from the Applications folder and logout/login or reboot. Now DT Pro should have the shortcut. It’s also possible, using third party utilities, to reassign keyboard shortcuts. (I’ve never had any luck with the keystroke changes possible in System Preferences.)

Pffffff the culprit is my stupidity. I modified the keyboard shortcut with Service Scrubber :blush:

Normally I’m not that stupid, honest!

Mori uses the command-) shortcut for Make New Entry Without Styles in the Services menu, which I’ve reassigned to option-command-) using Keyboard Shortcuts in System Preferences (even though it doesn’t appear there anymore; old bug). There’s another fairly common app I’ve tried before that competes for that shortcut but I can’t remember it now.