Import importing folders, but not importing many files

One of my databases got messed up somehow. I couldn’t move anything from the global inbox into the database (when I tried to drag it, it would “pop” back, and not show up in the database’s inbox). I ran “verify and repair” on the database, and it found 13 orphaned files, but there were none showing up in the Orphaned smart group. “Rebuild database” was grayed out in the menu, so that wasn’t an option.

I ended up selecting and dragging everything from DTPO into the Finder. I then created a brand new database, and ran the “import files and folders” menu command to import everything back. My folder structure imported fine as groups, but it looks like only a small portion of the files within those folders were imported, as a number of my groups are empty. (I verified that the files are present in the Finder).

Is there something I’m doing wrong? Is there a better way to import folders and files into DTPO, that will preserve my folder structure? (I’m using standalone databases, as opposed to indexing files and folders).

Thanks for any help.

Problem solved - I was out of space in the sparse bundle where the database resided. I had set it up with enough space to last quite a while, given current usage patterns, but in deleting files repeatedly in an attempt to fix this, it filled up. When I emptied my trash in Finder, and reclaimed several GB, it then imported fine.

Nothing to see here . . . move along. :smiley:


You’re not the first to do that, evank. 8)