Import of some .enex files fails

Like many, I am trying to migrate out of Evernote and Devonthink seems to provide all of my must-have features…as long as I can successfully get my data from Evernote into DT, which is where I’m stuck.

I exported my Evernote by notebook, so I have ~12 notebooks to import. Out of those 12, 9 of them imported (more or less) fine. (They imported and showed some number of files, but matching the numbers is a challenge because of how DT handles the import - that’s not the issue I’m worrying about right now.)

The problem is that some notebooks seem to import - try to import - but just quietly create a group with the name of the notebook and…stop. No notes in it, no contents, no errors. Always the same notebooks, and there’s no indication of why those notebooks refuse to actually create content. They’re not the largest notebooks (the smallest has ~120 notes, the largest has ~2000) and the contents are generally the same as other notebooks that imported successfully.

I’ve tried creating a new database, relaunching the app, any number of things, but some of the content just will. not. import.

Is there a more detailed log that might have info when the log shows nothing? Any idea why these notebooks simply will not import?

Welcome to the DEVONthink forum.

I searched the FAQ on DEVONtechnologies’ web site and found the following. Does this help?

Welcome @Liss

We don’t control what Evernote exports. Did you read this?..

I did read both of the linked articles. My issue isn’t getting things OUT of Evernote - that worked fine, and I’ve been able to test that the .enex files that DT won’t import are able to import successfully (back into Evernote as well as into a number of other apps).

What I’m hoping is that there’s some more detailed log or some way to force DT to actually import these files. If not, then I’m dead in the water, so to speak.

What version of Evernote did you use to create the file(s) you are trying to import?

The most recent version - 10.58.8. I exported each notebook as a single .enex file. I also tried limited the size of each file, which results in more total files but the roughly same overall percentage refuse to import (and always from the same notebooks). I suspect it’s because specific note(s) are causing a problem, but have no way of knowing for sure whether that’s the issue or something else.

I can’t connect directly to the legacy version of Evernote - or more precisely I can connect to it, but it’s refusing to sync properly and so is out of date, so I don’t want to import from there until (unless) I can resolve that.

I think you have discovered the source of the problem. Please re-read @bluefrog 's blog post, linked above.

I have read the blog post. Multiple times. According to the blog post “Drag and drop the exported file onto DEVONthink’s dock icon to import it. The notebook will be imported as a group bearing the name of the notebook.”

Except that it isn’t.

Then it says “If exported to .html instead of .enex, it will display correctly though it’s only cosmetic and can’t be used like in Evernote.” I have no idea what this means “only cosmetic and can’t be used like in Evernote” - what exactly “can’t be used”? This sentence seems to imply that some unknown part of the content will break or be unusable, but does not provide any clarity.

Is the version of Evernote you are using the “Legacy” version?

No - as noted above, it’s the most recent version (10.58.8) because the Legacy version will not sync and does not contain the latest version of my notes.

Well … you’ll have to discuss with Evernote Support, I guess, to find out how to make the backward transition to the Legacy version to enable import into DEVONthink. Or perhap they have other ideas.

Or someone here may have a better idea beyond that already documented by DEVONthink.

There’s an Enex to MD tool at GitHub:

perhaps that can help.

2 Likes