import problems from pdfs: no text

hi, since using the last version i have very often the import-report-result, that there was in the document “no text”. i changed between text-lightning and internal pdf-to-text but it happens often with both. and this with documents, where it didn´t happend before. any suggestions? :question:

Are the PDFs protected, e.g. that they cannot be printed? This prevents our pdf-to-tex engine (which we always use for extracting the text of PDFs) from working correctly.



no. they are not protected. some of them have been imported before. after you repaired my database without pdfs i had to import them again and realized there the first time “no text”. i receive weekly datasheets as a subsciption and there was formerly no problem (but no report either in the old version… ). now i get the message.
in addition: in the search function i realize that sometimes you have to finish the word before it is recognized. for example “heteroske”: no documents, but “heteroskedastizität”: many documents. best regards, stefan

Strange. Have you tried to re-install DEVONthink? Maybe the integrated pdf-2-text engine is somehow broken. If yes: Could you e-mail me such a PDF so that I can have a look why it makes such problems?

This depends on your search options. Make sure to have “phrase” enabled when you’re looking for parts of words.



Same problem, but even more funny, with version 1.9: Because the Pro-Edition is still “coming sooooooo…n” and I need different archives for “work” and “private” use, I use DevonThink in two different user accounts on my PowerBook G3/400. Until the update on version 1.9 everything worked without any problem.
Now I still can import pdf-files in the work environment, and in DevonThink it correctly comes as “pdf+txt”. But in the private environment with every pdf-import (also if I try the same files as in the work account) I get the message “no text”, and in the database it is saved as image file.
I’ve already tried different solutions: Re-organizing and optimizing the database, substituting the application with a new download, deleting the file com.devon-technologies.think.plist in the preferences of the private account, substituting the preferences file by the file from the work account, but it makes no difference. I tried to rebuild the whole database, effect: warning “no text” for ALL pdf-files in the database. The pdf-files are not locked, I even changed the ownership. All settings in DevonThink are the same in both accounts
What’s wrong??


Mike, what happens if you set your preferences to import PDFs with plain text conversion?

If I change the preferences to plain text conversion, the import result is an empty document (0 words, 0 characters) …

Lanassa and Mike:

Check Eric’s offer (earlier in this thread). You can send an email to DT Support, including a description of your problem and attaching a sample PDF that exhibits this problem when you try to import it.