Imported OPML loses text

OPML files imported into DTPO retain their hierarchical structure, but do not appear to import the text of the individual documents. (See Is this expected behavior?

I reverse engineered this (created a hierarchy in DEVONthink and exported it to OPML) and see that DEVONthink is expecting your elements to be title= and text=. If you use an editor or Xmplify to modify your file, then they should import. (Your example imports OK after it is modified.)

OPML is about a loose a standard as is possible and everyone’s parser interprets it slightly differently. E.g., Xmplify thinks DEVONthink-exported OPML is bad XML.

Thanks for the bug report, the next maintenance release will fix this.

@korm: As always, thanks so much. However, I guess I’m a bit of a luddite.
In my file the elements are (I believe) <outline text= and _note=. I tried different permutations of editing them, as you suggested, but cannot get the text to import. Would you be able to provide more explicit instructions? Thanks much.

If I open the .opml in TextEdit or some other plain text editor and do a global replacement of the string “text=” with “title=” and then a global replacement of “_note=” with “text=”, the import works.

Works perfectly. Thanks!

SUBJECT: quirks with importing my OPML exports from OmniOutliner

#1: I found I must add a sub-itme to every line in OmniOutliner for DTPO to create a folder. Is ther a way to avoid this. It creates clutter; e.g., I end up with many empty folders. What to do?

#2: The resulting folders do retain the hierarchy from OmniOutliner, but only the folders have any text content. Every text file inside every folder is empty. Folders have titles corresponding to the text content that I need to be imported as plain or rich text files. Is there a work-around, or is there a script that willconvert DTPO Groups (folders) to plain or rich text files? [Scrivener affords converting folders to text files, and vice versa).


Thank you for any help you can offer!
-Joseph Roberson

Actually the OPML import doesn’t support or create any tags at all. Could you send a zipped copy of the OPML document to cgrunenberg - at - Thanks!

Did you follow the procedure in my post of 3/25/2015, above?

If you do not change the OPML file as explained above, DEVONthink will assign the text in “_note=” elements in the OPML to Spotlight comments,

(DEVONthink definitely does not put anything in Tags.)

Here’s the .zip

Viktor’s (5.13 KB)

Reading your OPML source code, I assume your OmniOutliner source document has custom column headers (Booksequence, SequenceofViktorsjourney) and you have text into those columns in addition to the “note” field of the outline item.

Second, you have a number of texts (or perhaps paragraphs in the original file) that appear not to be associated with topic names. In other words, when I import your OPML back to OO5 there are numerous rows of blank topics.

As discussed in the older part of this thread – DEVONthink’s import of OPML is limited to two OPML attributes “title” (i.e., your “Topics” column in the original) and “text” (i.e., the content each Topic’s notes field in the original) – the rest of the file will be discarded or garbled. DEVONthink does not play well with custom attributes in OPML. You’ll need to rewrite the OmniOutliner source document to eliminate the custom columns, then change the OPML as describe on 3/5/2015, and then import that file into DEVONthink.

The import ignores unknown attributes and doesn’t set tags on its own. I just tested this - importing this file into DEVONthink Pro (Office) 2.9.15 didn’t create any tags.

Yeah, you’re right. I ignore the “exclude groups from tagging” setting. The import created group tags, not other tags.

I’m writing this off as a lost cause. I’ll just create oo3 outline, then manually create corresponding groups in DTPO. Unless you have a better idea.