Importing emails with accents

I noticed that emails I receive from France get their accents “re-coded” after importing(even after re-opening in Mail) - I a using import from View.

“Accusé de réception” ==> accusé de réception

Is there anything I could do to avoid that?


What is set in Preferences > Files > Emails?


Try setting the text encoding to UTF-8. And check the Character-encoding header in the original mail source. It’s perhaps missing or wrong.

@chrillek thanks
Character-encoding is missing, however it also says:
Content-Language: fr

Note that Apple Mail has no issue displaying the accents.

is DT checking that?
Will set UTF-8 and check what happens

Sorry, that was my bad. The header is called charset, not Character-encoding. You should have charset=UTF-8 in your email, looking at the source. Apple’s Mail is a bit terse when displaying the headers only.

The language setting is irrelevant in this context.

Mail clients have a long history of “fixing” broken emails. That’s why there is this “fallback encoding” in DT.


The view source does give [1].

Hopefully that’ll fix future emails.

Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 8bit


I just received another email from the same source in France and setting UTF-8 as backup did not fix the problem.
Since the email already has, what I understand to be the necessary charset information, I am not sure why setting UTF-8 as “backup” would help.

Is there something else I should try?


It’s a known issue, the next release will fix this.