Importing from Apple Notes is not working

Hello everyone,

after searching the forum for a possible solution I decided to post my issue here. I am new to DEVONthink and am already extremely happy with the program. I already imported several files and folders into DEVONthink Pro and now I wanted to reach the next level and import Apple notes and Evernote. Unfortunately both imports did not work. They started the respective program but nothing else happens. I already rebooted the Mac but this did not help. Then I checked all security / privacy settings but DEVONthink has full access. I am new to macOS so maybe I missed something?

I found the reason for Evernote in the Forum (Evernote 10 does not allow Apple Script) and will downgrade to the legacy version which should work.

However for Apple Notes I did not find a solution. I found one post where everything worked after a while. I waited a couple of days and tested several days even after rebooting (see above). I’m using macOS Catalina 10.15.7.

Can anyone help me where my mistake could be?

Thank you very much!


You could give this a chance.

Thanks. That might be an alternative if I can’t get the native import working. However I’d love to try to get that one working first.

  • Do you have Notes’ Preferences > Enable the On My Mac account enabled?
    • If so, disable it.
    • If not, do you have multiple accounts assocated with Notes?

Thanks for the quick reply.

I did not have that option enabled. However I did have multiple accounts associated (didn’t even know about that). I deactivated all and the import worked. Thank you very much for the quick solution!

You’re very welcome :slight_smile:

Just a quick update: The Import from Evernote did work with the Legacy App of Evernote. Just open it, download your data and then you can import from DT3. DT3 takes the data directly from the Evernote Legacy App.

Correct. Evernote removed AppleScript support in Evernote 10.

Hi. I am just in the process to migrate most of my data / information management to DT3.
Can get a lot working but Apple Notes seems to be impossible.
Was following some discussions and suggestions but
a) drag and drop from Apple Notes into DT3 seems not to work at all (checked whether “Enable on my Mac” as well as accounts - non of them are active)
b) another suggestion via DT3-> Import → Apple files and Attachments does just not appear on my DT3
Any idea what might be missing / wrong in my set-up?
Thanks in advance. Robert

Post a screen capture of the File > Import menu.