importing incomplete


I’m not able to import folders from one db to another, at least no completely. Links and txt files don’t get imported.

Exporting works fine. I also did check the integrity of the db.

Any idea what’s wrong.

Thanks a lot - I need to split the dbs

The recommended procedures for exporting material that’s to be incorporated into a different database:

  1. In the Finder, create a new folder that’s to be the recipient of the exported material.

  2. In the database that has material to be exported, select the groups/documents to be exported. Choose File > Export > Files & Folders. Choose as the target for the export the folder created in step 1.

Note: Dragging & dropping items to the Finder will lose metadata such as URLs and information in the Comment field of exported material.

  1. In the database that is to receive the previously exported material, choose Import > Files & Folders. Select ALL of the contents of the ‘target’ folder and confirm.

After confirming successful capture into the second database you may delete the exported items from the first database and also delete the Finder folder that had been used to make the transfer.

Does this help?

Nope it doesn’t work this way. Loosing rtf files and get files in to folder where ther were none. Looks like troubles with the metadata storage info?!


My current workaraound is to copy entire dbs and the delete what i don’t need. That’s of course cumbersome.

Further ideas, please.



It should work that way if there are no problems with the computer or the database. :slight_smile:

Have you run Tools > Verify & Repair on your database, to check for problems?


the database is correct at least according to the check. The files & folders are correctly exported. But the brandnew database doesn’t import them properly. I tried it at least 15 times with serveral different folders.

What do yu mean by the computer, what could cause the application to ex/import incorrect?

Thanks Thomas

Hi, Thomas. Just to check things out, I chose a group that contained 7,708 items (groups and documents) and exported it using Files > Export > Files & Folders to a target folder.

The log file showed that one file failed to export, a JPEG file damaged during editing.

Then I created a new database and imported the exported materials into it using File > Import > Files & Folders. The new database showed 7,707 items (groups and documents). The content included plain and rich text, PDFs, HTML, WebArchives, “unknown” file types and URLs (to external Indexed files). All of the metadata, including URLs of HTML and WebArchive documents, Paths (to indexed documents and to the files stored in the internal Files folder) and so on were complete.

Everything worked properly.

What can cause problems? A variety of possibilities: damaged files, something as simple as lack of disk space to hold the new database, or operating system and disk directory errors.

If you have installed haxies or other hacks on your computer, including third-party input manager plugins or QuickTime media plugins, they may have been poorly written or have ‘broken’ after an OS update. Hacks to the operating system are probably the most common cause of flakiness and instability on Macs. Most developers of OS hacks lack Apple’s resources for testing and quality assurance. Even ‘simple’ add-ons to Safari – especially if they involve an input manager plugin – can have unforeseen effects resulting in errors. A hack such as ShapeShifter is pretty much an unqualified disaster, judging by the problems it can cause.

Personally, I find the convenience of a rock-solid computer saves me more time and effort than the convenience or time-saving that might be promised by some of the add-ons to the operating system. So I keep OS X in pretty stock condition. :slight_smile:

Another source of problems is failure to keep the operating system and the disk directory maintained. I run routine preventive maintenance about once a week. A utility such as OnyX (donation-ware) or Co*cktail (ignore the asterisk - shareware) can help keep the computer clean of problems such as possibly damaged cache files and so on. I run DiskWarrior 4 about once a month to clean up and optimize the disk directory.

To the extent that you install things that modify the performance of the operating system or applications you increase the risk that errors can develop. If you do this, be careful and watch for problems. Keep such hacks updated, at the least. Remove anything that causes data loss or costs you time and effort to correct problems.

Well, I do have some hacks/input managers running. I’m just perplexed that it interferes with im/export.

Diskwarrior and Onyx are tools that I use regularily. Is there any chance that I find reasons for that behavior in the DTstorage files?

Thanks for taking care of my problem. I accept that I cannot resolve it. Hopefullly Leopard will do.


The DTstorage files are completely harmless. They simply carry over the metadata of the exported files.

It’s likely that Leopard will break some of your existing hacks/input managers, anyway because of code changes in the new OS. The reason they may be interfering with export/import is that one of them alone or several in concert may be addling your computer’s brain.

Apple engineers have sometimes discussed eliminating input managers, because they so often cause problems. That probably won’t happen, as input manager plugins make it relatively easy for developers to tweak things for their own purposes – but sometimes with unintended consequences. Another application making a call to the same code that was changed by an input manager may experience errors. And some people install several plugins, each of which tries to make its own changes to the same area of code.

Please check if all file types should be imported (see Preferences > Import).

hmm, the only thing that wasn’t checked is “Formatierte Texte” (Formatted texts).

Will give it a try later.


Update: I tried it once and I did import exactly what was exported before. Will try it with all my folders from before.