Importing Mail

Today I have downloaded DEVONthink Pro 1.2 and am evaluating using it. One feature that I want is the ability to import email. I see in the forums people referencing the included mail import scripts.

Am I missing something? I cannot find these scripts anywhere. Can anyone help me out? I did choose on running DEVONthink for the first time to install all add-ons.



The scripts appear in your global Scripts menu when your mail application is frontmost.

For Apple’s, there’s a script to capture one or more selected individual messages, and another to capture one or more selected mailboxes.

Note that the script captures only a plain text version of the message, without attachments. Note also that each captured message is flagged, so that next time the script is run it will transfer only unflagged messages.

BTW there will be a future release of an enhanced version of DT Pro (with a different name) that will automate scanning, OCR and transfer to the database. It will also be able to archive mail with better rendering and will bring over attachments.

Ah! Dummy me.

Hm. I will have to change my mail usage. I flag messages that I need to respond to but don’t have time to right now, or I am working on something more important, etc…

Great! I’d hate to ask for an ETA? Anywhere I can read more? :slight_smile: What do you mean a different name? I am thinking very much of purchasing DEVONthink Pro. Should I be waiting or purchasing something different?



I’m not aware of a release schedule yet. The developers work on the premise that software shouldn’t be released before it is ready. I approve of that, as I do much of my work on beta versions, and even those are remarkably bug-free. :slight_smile:

If you search the forum for OCR you will find several discussions.

Annard has discussed the mail archiving module in several posts.

No information on pricing at this time. The new version of DT with OCR capabilities will cost more than DT Pro, as there has been substantial development investment and DEVONtechnologies has to pay a license fee for the OCR engine. I don’t know whether the mail archive will be separately available as a plugin for DT Pro or only built into the “higher end” version of DT with the OCR capability.

Watch for announcements. There will be a public beta so that you can check out the software and decide whether you want it.

Note that DEVONtechnologies has provided “price protection”. If you were a registered user of DEVONthink Personal, for example, you were eligible to purchase registration for DEVONthink Pro for just the difference in price.

Christian recently posted: The scripts of V1.2.1 won’t flag the mails anymore.

Thanks, sjk, I stand corrected.

That’s what comes of always working with betas of the next version. I’ve been using the future plugin that also doesn’t affect the existing flag status of emails. And handles attachments.

I’ve gotten a lot of email from a colleague who always put what one would expect as the body of the message into an attachment. So his messages are entirely cryptic unless one reads the attachment.


I’ve tried to follow your clarification as noted below, but I can’t seem to find the “capture” script. It doesn’t appear in the global script menu when I have in the foreground. Nor could I find a “capture” script anywhere in the HD. I have found the Devonthink pro scripts folder.

What am I missing?

Anticipatory thanks,

david masuda

Appreciate the prompt reply - but I am afraid I still am flummoxed. When I open the global scripts (with Mail in the foreground) , I see the list of scripts in the /Library/Scripts folder. I can also open the User scripts folder and the Mail scripts folder, but former has only OmniOutliner scripts and the latter only an Accounttypes folder.

I’ve also looked through the scripts in the Users/…/Application Support/DEVONthink Pro folder and see the folder set that is described in the DEVONthink Help files (Addressbook & Mail, Comments, Data, etc.). I’ve run a Spotlight search on .scpt and I am still not finding the “Add message(s) to DEVONthink” script (BTW, I also don’t see an “Add page to DEVONTthink” script with Safari…)

One other thing, in either Mail or Safari, when i try to open the MAil or Safari Scripts folder from the Global Scripts Menu Bar, nothing happens - as opposed to Finder opening when I selecct the Open Library Scripts folder or the open User scripts folder.

Hope that clarifies…

David, after a long series of exchanges with another user named Paul, I think I know what your problem is. Some of your permissions have come adrift.

When you first installed the current version of DT Pro it attempted to install a number of scripts inside the Library folder of your User directory.

To do that, DT Pro needs to be able to add the items. But if your permissions were incorrectly set to prohibit modification, the scripts cannot be installed.

In the Finder, do this:

[1] Navigate to ~/Library/Scripts/.

[2] Select (don’t open) the Scripts folder and press Command-I to open the Info panel.

[3] Inspect Ownership & Permissions. It should read “You can Read & Write”. If that’s not what is displayed, change it so that you have permission to modify the contents of this folder. Close the Info panel.

[4] Are there folders inside the Scripts folder, e.g. “Applications” and “DEVONthink Pro”?. If so, repeat for each folder steps [2] and [3] above.

[5] Return to DT Pro and select Help > Install Add-Ons. Click Install.

[6] Switch to Mail. Select the global Scripts menu and check for the appearance of the scripts to add message(s) or mailbox(es) to DEVONthink.

Please post back to let us know if this worked for you.

That was it - nicely done!.

Perhaps it was OmniOutliner that change the permissions? I should add that I am a complete novice with Mac OS, having made the leap from MS just a month ago (after all those years on Windows boxes I now know what I’ve been missing)…

In any case, I grateful for your solution…

Hi There-

I just downloaded the DEVONthink Pro trial, and immediately noticed that I did not have certain scripts I have seen referenced in the manual and throughout this forum. I’m missing the various ‘Add Message to DEVONthink’ scripts for, NetNewswire, Safari, etc.

I found this thread, which fits exactly what happens on my machine… with the exception of the resolution.

I followed the posted instructions from above to check the permissions on the various Script directories, and they’re all set to Read and Write.

I do have a DEVONthink Pro directory in the ~/Library/Scripts/ directory, but it only has these scripts:
Copy Selection to Current Group.scpt
Copy Selection to Incoming.scpt
Copy Selection to…scpt
Link to current document.scpt

Nothing else.

The only other application that has a subdirectory here is Omnioutliner Pro (and its corresponding scripts).

I checked permissions as stated above, tried the ‘Install Add-Ons’ command from the Help menu, but I don’t ever seem to get the additional scripts. I’ve tried this multiple times. I’ve done extensive searching on my drive for the missing ‘Add x to DEVONthink’ scripts to no avail.

Anyone have any suggestions? It’s frustrating missing this vital (to me) functionality. I would really like to get this resolved so I can return to evaluating this great program.


bobbys, the Mail scripts should be in a folder named “Mail”, inside a folder named “Applications”, inside the Scripts folder of your User “Library” folder.

Also inside that “Applications” folder you should see other scripts for, e.g. Microsoft Entourage, Eudora, MailSmith, etc.

If you don’t see that folder named “Applications” inside the “Scripts” folder, select “Scripts” (but don’t open it), press Command-I to open the Info panel and again check ownership and permissions.

Try “Install Add-Ons” one more time, bring Mail to the front and look for a light font heading, “Mail Scripts” and under that the two relevant scripts. (Don’t look inside the DEVONthink Pro folder or any other folder.)

If the Mail scripts still aren’t there, you’ve got a somewhat weird computer. :slight_smile:

Send me a message (with a reminder of the problem). Help > Support. I’ll try a brute force approach to get the scripts working for you.

Well, consider my computer officially weird!

I tried the procedures above, and it didn’t work. I will now use the Help > Support command to continue this discussion.


We did succeed in getting bobbys up and running after he contacted Support.

And yes, I still think there’s something weird about his computer. :slight_smile:

Oh, please do include mail archiving as a plugin for DT Pro. Considering the price of OCR software, I’m guessing that the “higher end” version will be out of my range.

Hi All,

I’ve been reading this thread as it seems to relate to the problem i’m having. I have no DT scripts in my I checked the permissions, changed them as advised and re-installed DT Pro, to no avail.

Disk utils found and repaired lots of wrong permissions on my startup disk but still no better.

I found the scripts buried in the main DT Pro app container and moved them to ~/library/scripts/mail folder. This allows them to show up under mail in the script menu while in mail, but they are not placed at the top of the list as they should be.

Suggestions as to what might be wrong anyone?

The scripts for Apple’s Mail application should be at:


You can use AppleScript Utilities to place the Library scripts near the top or the bottom of the Scripts menu panel.

My thanks Bill. It’s always best to flag one’s ignorance with the first post to a forum don’t you think?


On the brighter side I now know what that pesky ~ key means.

I’m off to read some books.

BTW, is it usual for the library folder for a user to be read only for that user?

Thanks again :slight_smile:

No, the user should have read & write ability.

If the permission is set as read only, then DT Pro cannot install scripts.

I can’t find any /Users/qtus/Library/Scripts/Applications/Mail folder. All the folders above have the right read/write permissions. Even if I create a Mail folder inside Applications and install the add ons nothing happens.


Which application are you using?

Scripts are not available for DEVONthink Personal.

In DEVONthink Pro Office, a Mail plugin is installed and email archiving commands are placed under the Mailbox and Message headers in the menu bar.