In Preview, OCRed PDFs show gibberish in sidebar

I haven’t noticed this before, shows you how observant I am, but when I use Preview to open an OCRed PDF, I get gibberish in the sidebar. Something like this:
▾Page 1
▾Page 2

I can’t drag pages out of the sidebar to add to other PDFs. Why is that?


  1. That’s the Table of Contents view in the slide-out drawer. Except for the page number, the logic of text placed there escapes me. Which is why I usually set the drawer display to icons of the pages. :slight_smile:

  2. In Leopard and Preview, you can drag a page from the icon bar of one PDF document and insert it into the icon bar of a second document at the desired location. It’s easiest to do when the two PDFs are displayed side-by-side in Preview and the icon drawer is visible in both documents.

Exactly! So how do I force Preview to display the icons in the sidebar instead of the garbled table of contents?

And how did Preview come up with a table of contents in the first place?



Edit: Found how to switch from table of contents to icons. It’s a little, teeny button on the bottom of the sidebar.

I have this exact same problem.

One can either choose to have the sidebar display a thumbnail of the document or close the sidebar completely. However, the moment a new document is opened, the sidebar re-appears with the Table of Contents again.

Please, I am sure everyone else should be having this problem. What is the solution?

My solution is using a different application as a default pdf viewer. In Skim the TOC does not open by default. Instead, you have a wider range of choices and a great interface for highlites, notes and bookmarks. The only downside: Currently, Dt does not display your annotations from skim.

Preview is, of course, a separate Apple application.

If you don’t wish to have a PDF open to automatically display the Table of Contents in the sidebar, 1) make certain that Preview > Preferences > PDF doesn’t have the option checked to open the sidebar only for Table of Contents; 2) uncheck View > Sidebar (there’s a keyboard shortcut to toggle this). Now PDFs will open without displaying the sidebar.

When you first open a PDF, or at any time, you can open the sidebar and instruct Preview which option (Annotations, TOC or Thumbnails) should be displayed for that PDF when the sidebar is opened. That’s done with the action button at the bottom of the sidebar. The setting will be remembered next time that PDF is opened.

Preview keeps getting better. In Leopard one can now delete a page from a PDF, or move a page from one PDF to another.


Thanks for the detailed reply.

Yes, I had run through Preview’s settings. I had unchecked “open the sidebar only for Table of Contents”. I had also set the sidebar to display thumbnails instead of the table of contents each time I opened a file scanned by DT. Preview does not remember sidebar settings. Each PDF I open still displays gibberish in the sidebar.

There’s no control of this in DEVONthink Pro Office. The IRIS OCR engine produces those “bookmarks” in the PDFs. Preview sees the PDF as defaulting to display of bookmarks.

If I annotate a PDF in Preview or Acrobat and before saving the changes set the slideout to display thumbnails, that will become the default for this file next time it’s opened in Preview.

Those bookmarks generated by the IRIS engine do work, although they often don’t make much sense. I’ll make a note to Annard to ask whether a future change in the IRIS engine might remove bookmark generation. Of course, that change would have to be made by IRIS.


Thanks for the informative reply again.

I see the problem extends not just to DTPO but to the IRIS engine. I have confidence that DEVON can resolve the issue.

Would you say the only solution now is to use either Acrobat (heavy, resource-consuming) or Skim as the default PDF reader?

I’ll confess that my solution is to use Preview as the default PDF reader, and ignore the TOC display. It doesn’t bother me, as my attention is focused on the information in the PDF. :slight_smile:

The documents processed by DTPO causes Preview to display the TOC but also causes Preview to zoom to a certain section of the document.

I noticed normal files are opened by Preview with 100% zoom or are “maximized to the size of the window”. Files by DTPO are opened with the window zoomed to a certain part of the document. (sorry for being so long-winded, but this might sound confusing so it bears repeating.)

Did you ever notice that?


Bill DeVille wrote:

The ability to add markup that DT can display is wonderful, but I’m having trouble with PDFs in which I have used Preview to move or delete pages.

If I mark up a PDF that is basically ASCII, the text remains in ASCII and it is indexed as well as displayed by DT. But if I move pages around, Preview seems to save the entire contents in a binary format. DT displays the new file just fine, but can’t convert it to TXT/RTF, and can’t index it (“No text”).

Has anyone else noticed this, and if so, is there a workaround that doesn’t involve Adobe Reader?

Footnote 2008-12-14: This doesn’t seem to apply to all – perhaps most – PDFs. Perhaps I was just unlucky in my original choice of files to edit. In any case this is not a problem with DT per se, but it is something to watch for.