Inbox.dtBase2 Major Error

I had to wipe my MacBook Pro apps, data, etc. from a Time Capsule backup. Everything generally went well, with one apparent exception. When I open DevonThink Pro 3, I get the following:

Initial Verification: Inbox.dtBase2

Found 1 major file errors. Please restore the last backup or rebuild the database and verify the contents afterwards!

My choices are to Ignore, Rebuild, or Restore from a backup.

If I choose Ignore, it appears I can’t save anything new to my global inbox. Also, I get the same error message if I quit and restart DTP. Choosing Rebuild doesn’t seem to do anything; I still can’t save anything new to my global inbox, the error message reappears on a quit-and-restart; and I can’t find a backup of my Inbox.dtBase2 file in the location where DevonTechnologies FAQ says it would be.

Please help!

Randy Stokes

Is there anything worth rescuing in your inbox? If not, what happens if you delete the inbox from Finder and then restart DT (I’m wondering if DT then just creates a new inbox)? Or reinstall DT after deleting the inbox - that must create a new inbox. If there are only a small number of files you need from your (current, broken) inbox, you could extract them later if need be (in that case don’t delete, but rename and move to a different location); we can do that bit in a second step.

(PS where were you expecting there to be a backup of the Inbox file in accordance with the FAQ? I wasn’t aware of any such automated backup.)

Are you seeing a crossed pencil icon to the right of the database’s name in the Navigate sidebar?

Blue-frog, yes I am!


This can happen when restoring from Time Machine or using Migration Assistant.

Try this…

  1. Quit DEVONthink.
  2. In the Finder, press Shift-Command-G and paste: ~/Library/Application Support/DEVONthink Pro 2.
  3. Select the Inbox.dtBase2 file and press Command-I to show the Info pane.
  4. At the bottom, you’ll see Sharing & Permissions. Click the lock icon to unlock it.
    You will be prompted to enter your administrative password. (This is the password you use to log into the account).
  5. Make sure the account marked (Me) is set to Read & Write.
  6. Click the Action menu (gear icon) and choose Apply to enclosed items, if it is available.
  7. Relaunch DEVONthink.

If that doesn’t resolve it, do this…

  1. Quit DEVONthink.
  2. In the Finder, press Shift-Command-G and paste: ~/Library/Application Support/DEVONthink Pro 2/Inbox.dtBase2. Leave this window open.
  3. Open /Applications/Utilities/
  4. Type: sudo chmod -R 775 , then a space, then drag and drop the .dtBase2 file into the Terminal window. Press Return.
  5. It will prompt you for the Administrator password. Enter it (noting it will be invisible when you type it) and press Return.
  6. Type: exit , press Return, and quit Terminal.
  7. Relaunch DEVONthink.

Jim, I tried both of these and neither one worked. I’m still getting the error warning when I re-launch DevonThink Pro, and there’s still a crossed pencil icon next to the inbox.

Thanks. Any more ideas?


I selected my Inbox and checked Database Properties. There, it indicates my Inbox.dtBase2 file is actually in the DevonThink 3 folder (not in the DevonThink Pro 2 folder). Should I try your suggestions using THAT file instead?


You did not mention that you are working with DEVONthink 2 and not 3. I suppose Bluefrog by accident copied an old help text about DT 2 into his post.

So when you actually are using DT 3 you should try what he suggested with the inbox.dtBase2 in the DT 3 folder—both versions of DT have their own inboxes and both programs use the .dtBase2 file format.

No, I am working with DevonThink Pro 3. There appear to be Inbox.dtBase2 files in BOTH directories (i.e., DevonThink 3 AND DevonThink Pro 2).

Actually, I went ahead and tried both of Jim’s suggestions using the Inbox.dtBase2 in my DevonThink 3 directory, and neither worked. I’m still getting the error warning when I reopen DevonThink 3.


If you open the info pane for the Inbox.dtBase2 file in Finder, is the file still marked locked? Are the privileges at the bottom of the info-screen as you would expect (that is yourname (me) has Read & Write)?

No, the Inbox.dtBase2 file does not show up in the info pane as locked, and my privileges are shown as Read & Write. (Before anyone asks, that’s true for the versions of that file in BOTH the DevonThink 3 directory and the DevonThink Pro 2 directory.)


have you tried restarting your mac since performing the manoeuvre Jim recommended?

By the way, I DO have number of files still in the Global Inbox. I often let those pile up for a while, then go in and use the Classify function to file everything in appropriate groups in my database.

Blanc – yes, after doing the procedure on the Inbox.dtBase2 file in the DevonThink 3 and in the DevonThink Pro 2 directories. No change.

if you select show package contents from the context menu of the Inbox.dtBase2 file (we are talking the one in the DEVONthink 3 folder, only that one is relevant to DT3) and then select any of the files and open the info pane, are they also showing as not locked and with appropriate privileges?

I assume you are talking about the .Meta and .MetaStore files. I checked them all, and none of them is locked, and all show appropriate Read & Write privileges.

I’m out of ideas - other than the suggestion I originally made, namely removing the Inbox file (to a different location), letting DT create a new one (either automatically - don’t know it that happens - or by reinstalling). Can you access your files in the inbox currently? Then you could simply copy them to a new database and put them back in your new inbox later. The slower variation would be to copy them from the “Files” folder which is unhidden when you do show package contents and then later reimport them. Of course, you might just want to wait until Jim gets back out of bed and writes back :wink:

I am able to open and read documents in my current Global Inbox. However, I don’t appear to be able to drag any of those documents into my primary database (or into a Test database I created to try this out). And, of course, I can’t add any new documents to my Global Inbox.

For now I think I’ll wait to see if Jim has any other ideas.



No, that’s no surprise, as you can’t write the change to Inbox; but can you copy (ie duplicate) the files to another location?