Incorrect display of favorites

Normally under “Favorites” active databases are greyed out and displayed normally when they are inactive. For some time now, I have been using the opposite approach: inactive databases are greyed out.
How can I restore the normal state?

If you are using encrypted DBs it’s possible this is linked to automatic renaming of databases. Have a look and see whether your closed databases have a file-ending .dtSparse (which is how it should be) or .sparseimage (which they should only display when open).

If that isn’t the solution, please post more information, such as how you open those databases which are closed, but grey in the favourites.

Thanks for your feedback, @Blanc.

I cannot imagine that the automatic name change of encrypted databases is the cause of the problem. Before opening, the database is called XYZ.dtSparse, after opening it is called XYZ.sparseimage. So far everything as intended.

When I open a database, I usually do this by double-clicking on the database in the favorites list. But even if I activate the database via the “Open” option, the problem remains with the wrongly displayed favorite name (not grayed out instead of grayed out).

I have already tried the following (unsuccessfully):

  • Repairing and optimizing the database
  • Rebuilding the database

Important note:

  1. the problem only appears with 1 Mac. On the second, synchronized Mac, the favorite name is displayed correctly.
  2. the problem appears only with 1 database. Six other databases are displayed correctly.
  • Did you try removing the favorite and adding it again?
  • Are the databases stored in an inaccessible location?

PS: I’m not seeing greyed out names for open or closed databases, but I would logically expect closed databases to be greyed out.


  • Favourites have been removed and added again several times.
  • The database is in the folder “Databases” in the home directory (not in a cloud folder!).

I had to rebuild the database in question months ago, and if I’m not mistaken, I’ve had the selfish behavior ever since. Once again, for all other databases, the favorite name is displayed normally when the database is closed and outgreyed when the database is open. - Well, it’s actually a luxury problem… :smile:

Maybe, as @Blanc has written, it’s actually due to the automatic name change when opening an encrypted DT database (dtSparse --> sparseimage)?

That’s unlikely, as you describe the database changing name as designed. You can test that, however: with the database closed select Show in Finder from the context menu for that database in the favourites. The database should be shown in Finder. Doing the same with the database open should do nothing. An even simpler test would be to click the greyed out database name; if that opens the database from a closed state, then the entry in favourites is pointing to the right file, and it’s got nothing to do with the automatic renaming of the file.

No, other way around; in the “favourites” section in the navigate pane, closed databases are black (so you can select and open them), whilst open databases are grey (they are already open, so you’d have no further need to select them). Apparently for other items in the favourites, the opposite is true: page 80 of the handbook says “If you see a favorite is greyed out, it means the containing database isn’t open.”

The same page also says “Double-clicking the item will open the database, if possible, and display the item.” - @do-it presumably the favourite in question is a database, and not an item in a database? There’s no way you’ve, say, linked the inbox of the database, rather than the database itself?

This is true if the display is correct. But in my case it is the other way round. If the database is closed, it is displayed under Favorites outgreyed, but cannot be displayed in the Finder (file name dtSparse). If the database is open, i.e. normally displayed in black under Favorites, I can display it in the Finder (filename .sparseimage). For all other databases, it behaves the same way as described by you.

@do-it presumably the favourite in question is a database, and not an item in a database? There’s no way you’ve, say, linked the inbox of the database, rather than the database itself?

It is the database itself, not a part of it.

Ok, then the problem seems to be that you have a favourite pointing to XYZ.sparseimage rather than XYZ.dtSparse. You said you had tried removing and adding back the favourite; perhaps you could try variations, such as removing the favourite when the database is open or closed, and restarting DT before adding back the favourite. Else perhaps @cgrunenberg has knowledge of the technical workings of “favourites” and can therefore point to a solution.


Thanks a lot for your help. Unfortunately, your tip cannot be implemented because favorites can only be set if the database in question is open. But then the Finder points to .sparseimage.

If I close the database, the Finder will continue to search for .sparseimage, but will not find it because the file is now called .dtSparse. Somehow I would have to make the Finder point to dtSparse and not to sparseimage.

The current release has some issues related to favorites & encrypted databases, the next maintenance release will fix them.

Okay, thank you very much. Then we practice waiting…