Indexed folder does not get updated

I added a indexed folder to one of my databases where I can drop images from outside of DT.
However when I add a new image via finder it does not show up in DT. Am I missing some setting?

Please provide more specific information when reporting such things, e.g., where is this indexed folder?

The indexed folder is on my hard drive.
I added it via File-> Index Files and Folder to my database.

It is just a folder where I can drop a file which should then be added to DT.
In DT I have a smart rule for that group which runs "on import’ but those files never appear in that folder in DT and thus the smart rule is not executed

Is this a cloud folder?

no, its just a simple folder. /Users/kaputtzimon/myfolder.

It is weird because I already have such a indexed folder in my other db where another process adds videos, those videos then appear in DT. And this works perfectly…

Is the folder added after using File > Updated Indexed Items for the enclosing indexed group?

no, but I clicked on File-> Updated Indexed Items afterwards with no result

Was the enclosing indexed group selected before using this command? Anything logged to Window > Log?

nothing in the logs.
I am not sure if it was selected, but I removed the folder and added it again without selecting anything.

same behavior… when I freshly add the folder all files are there in DT but when I add another file to this folder in Finder, this new files does not appear in DT.

A screenshot of the indexed group in DEVONthink and of the same folder in the Finder for comparison might be useful, thanks!

1 Like

Screenshot 2022-05-26 at 21.18.35

I also tried it me other folders / with empty folders at start… but no matter what I do, whenever I drop a file in the folder it does not appear in DT

Have you emptied your database’s Trash?

You are sure you have updated the index? Menu : File → Update Indexed Items for that database?

@BLUEFROG no I have not, if possible I would like to avoid this.

@rmschne so… I tried to update the indexed file again and then the missing file(s) appeared ( I prop. did something wrong the first time). But when I then again put a file in the folder, DT does not index it.
Or at least not in the 5 Minutes I waited

Why? The Trash isn’t another filing cabinet. (Neither is the system Trash.) In fact, we blogged about this very recently…

1 Like

@BLUEFROG ok, I emptied the trash now. The files still wont show up, only when I hit “updated indexed items”

[Edit] It seems not to work for new items, not sure why though

  • Is the Finder folder synced by some other process?
  • Do you have this folder indexed in more than one location in DEVONthink?

The Finder folder was not synced with any other process, but I tried to remove it in DT and readd it several times.
But it works now, I guess the trash deletion did the trick.

Thanks for your support!

You’re welcome and I’m glad to hear it’s working now. :slight_smile:

1 Like