Indexed items missing

Hi folks – Yesterday I moved a large group of audio and video files out of Devonthink proper, where they were taking up too much space on the hard drive on my MacBook Air, onto an external USB hard drive, whence I then indexed them in DTPO. THat seemed to work fine right after I did it, but today DTPO is telling me the indexed files are now missing – even though the hard drive is plugged in and I can see the files sitting happily on it.

Any ideas?


In the Finder, select Go > Go to Folder and enter: /volumes . It’s quite possible the drive mounted incorrectly and has a suffixed number on it. If that’s the case, the file path would be incorrect, so the files would be reported as missing.

Did “go to folder” as suggested, and the drive showed up fine in the finder window. (Or was there something else I was supposed to be looking for, other than the drive’s simple presence?)
Could the problem be that the indexed folder on the drive is named “AW a/v fr Air - 2018-07-20” while in the “file missing” alert in DTPO, the slash ("/") in the folder name shows up as a colon (":")?


The name if the volume. If it has a suffixed number from a mounting issue, like myDrive 2. This would break things.

It shouldn’t be, but it is not a good idea to use punctuation like this in filenames.

Nope. No numerical suffix.
Could the problem be that my external drive also harbors my TimeMachine backup (in the usual folder named Backups.backupdb)? Does that need to live on a partition of its own, rather than next to the new folder I’ve created for my now-indexed DTPO a/v files?


It doesn’t have to, but generally an entire drive or partition is devoted to TimeMachine.

In the Finder, make sure the Path Bar is enabled in the View menu. (It should read Hide Path Bar when it is enabled.)

Locate the file in the Finder and open the window large enough to see the path when the file is selected. Take a screencap of the window with the file selected. Also, take a screencap with the same file selected in the DEVONthink database, showing the file missing message.

In DEVONthink, hold the Option key and choose Help > Report Bug and attach the two screencaptures along with the other info it sends.

Thanks – When I compared the two screen grabs, I realized there was a difference between the two paths. I just re-indexed the files, and they seem to be working now.