Indexed Swift File from iCloud files not appearing on iPhone but does appear on iPad

I am running Devonthink on the Mac as well as iPad and iPhone.

I have a folder in iCloud that I have indexed and the folder contains txt files that have filename extensions of .swift

These files can be seen in the file view pane on the mac as well as on the iPad. Under the filename in the iPad it says they are plain text and the size.

The problem is that by the iPhone it says that the file is unknown and does not appear in the file view pane.

If I share it I could open it in a different app.

I would like it to be seen in the file view window like by the iPad

on the iPad

and on the iPhone

There is no support for arbitrary extensions like this in DEVONthink To Go. In DEVONthink you can add additional plain text extensions via a hidden preference, but there’s no such mechanism for iOS.

We can consider this a feature request.

but why does it work on the iPad ? The first picture is an iPad.

Sorry. Didn’t have my glasses on and it’s been another very long day, so I missed that.

Hold the Option key and choose Help > Report bug to start a support ticket. Please attach these files for me to test. Thanks.

Don’t forget to sleep occasionally, dear Jim. You’re doing a fantastic job, and nobody who stops to think wants you pushing yourself over the edge!