Invalid encryption key on iPad

Hi all,

I’d be grateful for some assistance please!

Some background:
I have DT3 running on my MacBook Pro, Mac mini, iPad and iPhone.

I previously had it syncing via iCloud Cloudkit, but ran into some issues. I abandoned using DTTG on my iPad and phone and carried on using it extensively on my two Mis via a Bonjour connection. It has worked very happily for a few months.

It has got to the stage when I need access on my iPad and iPhone. So back to iCloud Cloudkit I go.

I cleaned the iCloud location using my Mac and set up from scratch. That has worked a charm on my MacBook, Mini and iPhone. However, when I try and sync using my iPad, I get the “invalid encryption key” message. I know the key is correct, as I’m pasting it from my password manager.

Do I need to clean the location from my iPad as well? Or something along those lines?

I have tried deleting DTTG from my iPad and reinstalling, but no joy.

Thanks very much indeed.

I wonder if @BLUEFROG can offer any of his usual helpful guidance as to the best approach to take?

Did you reinstall DEVONthink To Go?

I did. I deleted it and reinstalled.

Really odd, as the global inbox is syncing properly, but it isn’t loading any of my other databases, and it says “invalid encryption key” below the global inbox.

Check the encryption key on the Mac…

  1. Do a Spotlight search for Keychain and open the Keychain Access application.
  2. In the logins section on the left, look for a key named DEVONcloudy Encryption (name of service) like DEVONcloudy Encryption (Dropbox).
  3. Double-click it and check the Show password checkbox. You will be required to enter your Administrative password. (This is the password you use to log into your machine with.)\
  4. Press Allow (or Always Allow, if desired) and the password will be shown.
  5. Take note of the password, then quit Keychain Access.

Thank you for the response.

I have followed those steps. I am encountering the same issue. I was using the right password, and my MacBook and Mini are syncing correctly. It is just my iPad.

The Global Inbox is syncing correctly, it is just not giving me the option of loading the other databases.

Are you able to successfully verify the sync store on the Mac (see contextual menu in Preferences > Sync)?

Interestingly, when I tried to verify, I got the following in the log. But the databases are still syncing.


CleanShot 2021-10-06 at 10.13.49@2x

One possibility is that different encryption keys were used on your devices and that this sync store contains now inconsistent data. The easiest way to fix this is probably to disable the sync location on all devices, then clean the sync store & upload your database(s) from the Mac again and finally enable the sync location on the other devices (after ensuring that the encryption key is the same first).