iOS 17 Files App and DTTG not working together

Hi there,
The integration of DTTG with the Files App seems to have stopped working recently, most likely with the iOS 17 update. Here are two screenshots (from the German version)

It’s all set up as it was working before. I’ve also tried disabling and enabling DEVONthink in that menu and restarting the phone. The DTTG version is: 3.7.6 (the latest, I believe). It’s also not possible to save files from other apps to DEVONthink using the Share sheets for “Files”. The is just no ‘connection’ to DTTG from files. Sharing files directly with DTTG via “share” does work.

There is no known issue in iOS 17.
It appears you have DEVONthink To Go’s Settings > Security enabled and likely set to Immediately.

No, that’s off or „aus“ in German.

As I said, there’s no known issue and I can’t reproduce the behavior here.
On DEVONthink To Go’s databases screen, select ? > Contact Us to start a support ticket. Thanks.

I have the same problem on my iPhone ?
Pin is of ß
Please help
Thank you in advance

Problem has nothing to do with security settings
It is necessary to enable the devonthink folder in the ios files app see three dots in the upper right corner
=> Problem solved :smile:

1 Like

Welcome @MKi
Glad to read you found how to enable the document provider with DEVONthink To Go!