iOS Shortcuts: "Cannot Communicate with App" error in Create Item action" in Shortcuts

I am trying to create an iOS shortcut to capture text and use it to create an item in DTTG. But when I use the “Create Item” action in Apps->DEVONthink it fails with an error “Cannot Communicate With App.”

The error appears both when I try to specify a group for the new document:

And when I try to run the shortcut anyway:

Yes, I have DTTG on my iPad and iPhone.
Yes, DTTG is open.
Yes, I can do things like save a Web Archive from Safari to a DTTG.
Yes, I am syncing using iCloud (CloudKit) on iOS and my Mac.
Yes, things that I capture in the DTTG Global Inbox on the iPad show up on the Mac.
Yes, things that I capture in the DT3 Inbox on the Mac show up in DTTG.

Yes, I have tried handing the Create Item a variable instead of just typing the text in directly

Yes, I have tried creating a file or markdown document instead of a text document.
Yes, I have closed both apps, rebooted the iPad, and reopened the apps.

I am running iOS 14.8.1 on a 3rd generation iPad Pro.

Thoughts?

  • Have you enabled authentication in DEVONthink To Go’s Settings > Security?
  • What version of DEVONthink To Go are you running?

I have not enabled authentication, imagining that it would just be another hurdle. Should I turn it on? I would prefer not to have to authenticate each time I use the shortcut, if I can avoid it.

Version 3.2.4. That is the most recent version listed in the App Store.

No, don’t enable it unless you need it.

Hmm… I can’t reproduce this here.
Is anyone else seeing this issue?

I suppose I could try updating to iPadOS 15, but that seems to cause more problems with apps like Shortcuts than it solves. What version of iOS are you running?

iOS 15.

Definitely. Shortcuts on iOS 15 and Monterey is one of the crappiest things I’ve ever seen coming out of Apple’s software labs. A far cry from the marketing blurb associated with it.

I would claim that the PDFkit of Sierra is still the number one :grinning:

1 Like

I how to your richer experience. Or poorer, as may be the case here :sleepy: