iPad Pro 12.9 share extension no web archives

On an iPad Pro 12.9 with DTTG 2.7.8 (16484) on iOS 14.3, the web archive clipper is not working. Bookmarks are stored after choosing that option, also visiting the bookmarks from DTTG is fine (no firewall or DNS issues).

After opening the DTTG location where the web archive should be, I experience DTTG inconsistent crashes.

I have gone through the full databases update process after installing the new DDTG

Anyone with similar issues?

What’s the URL of the web page?

Here is the URL

I apologise for not looking beyond this particular website :flushed:. This was the first site I visited after the DTTG update. I should learn to not assume so quickly.
I tested a few other websites; they work well.

Some additional information, I checked this website on a MacBook with the Firefox clipper. That creates a perfect web archive

To generate a webarchive for this url it requires a number of web archives to be embedded within the main web archive. This is not currently supported in DTTG.

I tried clipping more websites, of diverse nature and complexity. More than half of them can not be clipped through the share sheet on an iPad Pro 12.9
Some websites don’t even trigger the option to capture a bookmark or web archive. Instead, rich text can be clipped.

After clipping, DTTG crashed and disappeared most of the instances immediately after opening the app. A second launch does not crash, but there is no clip.

I never observed this behaviour with the previous DTTG.
Let me know if I can help improving the app in any way

While annoying there is a workaround until this is fixed. Save to web archive via Safari and Files.app to Devonthink

1 Like

How to do this?

Within the share sheet of Safari there is an options link. There you can set automatic, PDF or web archive. Check web archive and then safe to files app. Within files.app you can select DEVONthink if the file provider is enabled.

I hope this gets addressed in a future bug fix. More than half of the web pages I want to clip fail. You only know if it fails after checking in DTTG. Doing that after each capture makes the feature practically unusable. There is no automatic fallback such as a bookmark to catch up later

Anything new on this topic?

Have you tired clipping the URL mentioned previously with the 2.7.8 release?

Thank you for replying.
I can not confirm for 100% sure that I clipped that website successfully before, but with 2.7.8 and earlier versions I have clipped hundreds of pages successfully from a wide range of websites on the same iPad Pro 12.9. With the current version, pages are not clipped from more than 50% of the websites, maybe even more. Clipping from the share sheet in e.g. Twitterrific on iOS also fails often.

I noticed that in the failure cases, the iOS DTTG app crashes immediately when opening. A second app opening succeeds, but of course no clip.
Clipping pdfs from a website is without problems.

Ruud

We will look into this. However, considering Apple is deprecating webarchives, perhaps switching to PDFs would be a wise idea.

1 Like

I would have no problem with pdf’s as clipping format. However, currently DTTG is not offering that clipping format when I want to clip a webpage. That is possible in the Mac version of DT pro, but as far as I know not in DTTG

Yes. this is noted.