iPad takes extremely long to synch, always!


I am a LOVER of DT! I use the latest DT3 and DTTG versions across all devices. My macOS, iOS, and iPadOS’ are all up to date!

My question is: why does DTTG on my iPad take SO LONG to update and sync? DTTG on my iPhone syncs almost immediately after I update files on my macOS. The iPad, however, takes forever (and sometimes never!).

It has been like this consistently since I started using an iPad with DTTG. I’ve wiped the app and started all over again. I’ve done all those obvious trouble shooting things. I really want this to work and I need it to, but it’s becoming unbearable on my iPad.

When I go into settings in DTTG and I hit the refresh button under Locations > iCloud it does nothing. The same with the cloud icon on the app display :frowning:



How large are the databases (see File > Database Properties…) that are synchronized to the iPhone/iPad? And which iPhone/iPad do you actually use and which device do you use more often? E.g. the background sync is fully controlled by iOS depending on your usage of DEVONthink To Go. Finally, the behaviour of iCloud is not always predictable - sometimes it’s really fast, sometimes it lasts forever.

1 Like

Thanks for this.

1 database is 67MB. The other 540MB. Both pretty small. They just don’t sync. 1 database did sync, which I created at the same time at the other two. It’s 150MB.

Yes, I use the iPhone a lot more. But I’ve left the iPad on all day… DTTG says it’s in sync/up-to-date when it’s not. iPhone synced in just a few minutes.

It’s an ongoing issue. From reading your comments, it sounds like there’s not much that can be done then.

if iCloud sucks would you recommending DropBox or something else?


It is quite possible iCloud has stalled - a condition over which we have no control, nor can we even detect it. We can’t reproduce this issue, and some have said it “just started working!”

Here are a few things people have said “worked” , though we obviously can’t test it since we can’t reproduce it. I would try them individually, starting with the simplest…

  • Reboot the problematic device(s).
  • In DEVONthink’s Preferences > Sync , disable the iCloud location and quit the application. Relaunch DEVONthink and re-enable the sync location again.
  • In iOS’ Settings > your Apple ID > iCloud, try disabling and re-enabling iCloud Drive and DEVONthink.
  • In iOS’ Settings > your Apple ID, sign out of iCloud and sign back in.
  • In macOS’ System Preferences > Apple ID > Overview, sign out and back in.

However, I would ask if you actually need to use a remote sync location. Just having a cloud account doesn’t make it the optimal solution for all situations.


Thanks, Jim!
On your last point, do you mean – maybe a local network is a better bet!

Thanks for the tip/reminder you’re probably right.

You’re welcome. Here are my thoughts on remote syncs…