Is there a setting to disable all auto-tagging?

I have tried selecting an entire database to exclude from tagging. No. Tried selecting non-app created smart groups in a database in order to exclude from tagging. No go. That checkbox is not available.

I just want to turn the “feature” off completely and manually assign my own tags. And I don’t want to do it selectively. I would like to disable it app-wide; for all databases, groups, documents, folders, files.

I’m not really clear about what “auto tagging” means in this context, but maybe the settings at the bottom of the Import panel in the application Preferences would affect the behavior you’re having trouble with?

BTW, if you need to remove unwanted tags from existing items, a Smart Rule can be used to do that.


If I could post a screenshot here I’d demonstrate. But example: I imported some docs, and DT created tags for a whole bunch of docs, with labels such as 19-01; 141; 72-1608400; but; Gp, and the list goes on. I don’t want these tags, didn’t create them, and they have absolutely no relevance to anything I’m working on. What they DO do, however, is drown my tags listings with so much extraneous junk that the entire tagging functionality is useless.

I don’t want the app assigning anything automatically.

The settings “convert hashtags to tags,” and “convert keywords to tags” may be the culprits, but I don’t now that I have hashtags in any of my documents, and I don’t know how “keywords” could even be chosen as I haven’t assigned any.

Please open the original file of a record with such a tag in Finder and check whether the tag is assigned there.

1 Like

So I did…I think it’s the “convert hashtags to tags” setting that is picking up account numbers on OCR of invoices, phone numbers, escrow documents, contracts. Any sliver of text that has a # in it is getting tagged. Since this is a real estate litigation database, there are TONS of transactional documents that use that symbol. I never put that together in my mind, as I don’t really “do” the whole hashtag thing anywhere in my life. To me it’s a pound sign and denotes either a quantity or an assigned number designation.

But the keyword thing perplexes.

Ok. In case you don’t want to have any tags on your records that you didn’t assign yourself there’s also a hidden preference (search “Hidden preferences” in help):

DisableFinderTags: DEVONthink no longer imports or exports Finder tags

Enabling this would affect both import and export, so in case you just want to make sure that you don’t import Finder tags you could create a Smart Rule that removes all tags on import.

1 Like

So I looked again…Lots of phrases that are not preceded by a # being picked up from documents. It’s gotta be that “Keyword” setting. Several (I just sample checked a few out of a few hundred) are web pages, so could DT be culling SEO terms buried in webpage metadata as “keywords” and assigning these as “tags?”

I’ve never used tags in Finder at all, so I don’t think that’s it. But I will follow your advice and do that. It seems there may be several contributing factors.Thanks.

Edit: So I went and looked at Finder. I don’t know if I’ve ever turned on the tags column. Turns out that a lot of docs do have finder tags, though I have no clue how they got there. But most of this material doesn’t originate on my machine or server, so I guess it’s being picked up when we receive document dumps. It’s just very strange. I now see that I could have a document dump of several hundred or thousand docs, and now that I’m looking, maybe 10% to 15% have Finder tags.

We sweep for viruses and other malicious content but we don’t sweep for irrelevant Finder tags when we load up docs to the server.

You can find a record’s Keywords in Inspector > Document > Properties

1 Like

Thanks Pete. I think I have a plan now for dealing with this. Much appreciated.


Select your database; choose File/Database Properties/Exclude Groups from Tagging.

Checking in a couple of months later…Problem persists.

Yes. EVERY database has “exclude from tagging” checked.

Are you sure that there are no tags assigned to the original files?

Asking because if your setup didn’t change it’s likely this is causing unwanted tags:

DEVONthink doesn’t generate tags on its own unless you are using Finder tags, group Tags in DEVONthink, nested tags in DEVONthink, or have tag options enabled in Preferences > Import.