Issue regarding indexing and updating folder


Just wanted to see if anyone could help.
I have indexed my Zotero files into a DT group/folder, and have used the smartlist group to display the pdfs (rather than Zotero’s folder structure) as mention in other threads.
When I first did this, I was able to delete files/pdfs from Zotero and the indexed document would automatically disappear from the DT indexed folder (as normal).
But recently, when I delete pdfs from the Zotero application, the indexed folder does not update, and the document remains in the list. Although, when I select it, it displays a “File Missing” message.
However, clicking on File > Update Indexed Items only removes the single document IF I have selected it.
I.e., if there are a few documents that have been removed/deleted from Finder (through the Zotero app), DT will not update the whole folder/group, but only individual documents.

This does not seem normal and if there is a setting I may might have changed accidentally, please let me know how I can get back to updating all indexed documents automatically.


EDIT: I’ve worked out that I need to select the parent folder (not the smartgroup) to update the whole folder in DT.
However, I’m still wondering why the documents remain in DT, despite them being deleted from the Finder.

Also, this is a separate issue (perhaps a separate thread is needed?), but my database with the indexed files is about 4gb - reflecting the size of the actual size of the Zotero storage (more or less).
I thought indexing files is a way to get the documents into zotero without taking up space on the disk? Is this something I’ve overlooked in the DT documentation?

1 Like

Yes, that’s preferable

I’ve had this happen, but it’s pretty rare–and usually when I’m making a lot of changes at once in Zotero. But also, my DB is smaller than yours.

(on a side note, the Server is presenting sizes in UKs again…)

What’s the path of the Zotero files/folder?

Are you using Zotero’s sync function?

but my database with the indexed files is about 4gb

As reported where?

What’s the path of the Zotero files/folder?

-/Volumes/Samsung T7/Research and Resources/Zotero-JurisM/storage
All my databases (DT & Zotero) are on an external SSD.
I was once using them on my mac’s internal disk, but then I moved them to the external.
At that time, any new documents added to Zotero didn’t show up in the indexed Zotero folder. And after asking here on the forum, someone (you, perhaps) told me the path might be broken.
Upon checking, it was. So I redirected the indexed folder’s path and fixed.
Then, after moving the databases back to the external SSD, I made sure the paths were matched, as they are now.

Are you using Zotero’s sync function?

Yes, but I was using the sync function when I first indexed the folder.

As for my database, the file size is indicated on my disk and in the disk info.
Perhaps I assumed that indexing files in DT would save storage space as that is the purpose for other applications (e.g., linking files in Zotero rather than storing them).

Personally I don’t mind as I have plenty of storage. I’m just curious about it. That’s all.

If both Zotero and DEVONthink synchronize the same files, then it’s very likely that this will cause conflicts. Maybe including the one reported by you.

E.g. in case of known cloud folders (like Dropbox, iCloud Drive etc.) DEVONthink does actually not synchronize the indexed files to avoid such conflicts, DEVONthink synchronizes only its internal stuff (index, metadata, thumbnails etc.). It’s up to the cloud service/app to transfer the files therefore.

1 Like

Can you post a screencap of DEVONthink showing the indexed Zotero group?

actually, I just double checked the database documents.
Upon opening the contents of the database in finder, I noticed that the files in the database are only taking about a gb or so of space, but there are 2 or 3 backups of the DB within the database. That’s why it’s so “large”.
So, it seems that indexed files do not take up “physical” space in the DB.

Question, how do I change the backup settings (such as how many to keep and how often to create back up, etc)?

So, it seems that indexed files do not take up “physical” space in the DB.

That is correct. The metadata - which includes the searchable text of compatible files - is where the space is used.

Question, how do I change the backup settings (such as how many to keep and how often to create back up, etc)?

This is not user-definable since DEVONthink 3 was released. DEVONthink stores two rotating backups, captured weekly unless you’ve done a File > Optimize Database or a File > Rebuild Database. Those commands set a new backup point and purge the older one.

OK. Thanks for the responses!

You’re welcome :slight_smile: