Issue to drag+drop email from Google folder/label location

I seem to have an behavior that I don’t understand.

I want to drag+drop an email message into Devonthink. I am using Apple mail to our university Google mail. I can drag+drop mail from my global email inbox. But, I cannot seem to drag+drop email that is stored in a “Google folder/label”.

Is this to be expected?

I can Add to Devonthink via the Message menu.


Can you provide a screen capture of where you’re dragging and dropping from?

Here it is.

The email message is within two folders deep in the Google folder. I tried also from one level higher up to no avail.

The email message drags over with the (+) sign as though it will be added. But it is not.

This is macOS 10.15.


OK. I think I know what the problem is. My folder names have emoji and what might be considered to be “special characters”.

:card_file_box: Projects → top level folder

     proj email > J Smith

I just tried a drag + drop from a folder called “test” in the Google list. The drag + drop worked.


Emoji in names are definitely not suggested. This is especially true in names in the filesystem, like database or filenames. However, I’m not seeing an issue with the drag and drop.

What is reported in Window > Log as it’s clear from the toolbar icon there is something logged there?

Import of 1 message failed.


Does the import work when using the Message > Add to DEVONthink 3 command in Mail?

Yes. That part works.


Is System Preferences > Security & Privacy > Privacy > Automation enabled for DEVONthink and Mail?