Issue with movie size and zoom feature

I am attempting to import movies, avi, mov, etc. into DEVONthink. Unlike what happens with .jpgs and other images, the movie is displayed greatly zoomed and there is no way to change that. All of the zoom selections are grayed out except for ‘actual size’ and nothing at all happens when I try to select it. It makes the movie huge and distorted. For example, one movie was enlarged to 247% of its normal size.

If I copy movies into an RTF file, it shows up and is playable until I leave the file. When I come back to it, the movie is not longer there and I have a link, which is not what I’m trying to do.

So I’m not sure how to make this work. I’ve looked through the documenation, and I have only found one other post that asks about this issue. There were no responses, so I have no idea what to do.

I’m totally new to this program, so I apologize if I am missing something obvoius. Any suuggestions would be greatly appreciated.

Alex W.


I replicated your experiences in DT PE 1.9.2. Linked or imported movies do display at a magnified size, and cannot be made smaller. That would seem to be a bug.

Then I created a new RTF file and dragged a movie into it. DEVONthink PE displayed an alert message, asking whether I really wanted to copy the movie or just make an alias to it. I selected ‘copy’. After closing that file and upon returning to it, only an icon of the movie was displayed. Then I created a second new RTF file and dragged the movie onto it. This time, when DT put up an alert message, I told it to create an alias to the movie. That works well. A playable image of the movie remains in the RFT file, even after quitting it and returning to it. (This behavior makes sense. Why would I want to physically embed a 39 MB movie into an RTF file?)

DEVONthink Pro 1.9 beta 10 behaves better. Linked or imported movies display at their normal size, although options to change the display size are greyed out. Dragging a movie into an RTF document and selecting the alias option also works properly in Pro.

Eric and Christian: Looks like this is a bug in DT PE that has already been (at least in part) fixed in DT Pro beta 10.

Bill & Alex,

zooming inside split views (of browser windows) will be modified in v1.9.3 as movies won’t be scaled beyond their original size anymore. In addition, the zoom commands can be only applied if a movie is displayed in a separate window (e.g. double-click on the movie or use “Data > Open”).

Finally, attaching movies to rich text documents is not (yet) recommended - the text engine of OS X handles this but can’t display movies without a file representation. Therefore the movie is replaced by an icon after closing and reopening the document.

Thank you, Bill, for replicating this issue. And to Christian for explaining. I am glad to see v1.9.3 will fix this issue. In the meantime, I will use aliases. I did try changing preferences to link to the original, and it did the same thing (where it displayed the movie really largely), but I did not try creating an alias in an rtf file.

Many thanks for the quick response!!


Just tried to drag a movie into an rtf file and this time it didn’t ask me if I really wanted to copy it and give me the option to select alias. It just put the movie in. I tried creating an alias and copying that into the file, but it sill turned it into a file icon when I cam back.

It did ask yesterday, so I don’t know what changed. I guess I’ll just hang in there until v1.9.3 before trying anything with movies.