Items sometimes captured to wrong database on iOS 14.3

When I try to get pdf from safari to DTTg 2.7.8 through sharesheet everything seems ok, but there is no resulting pdf in the inbox database later.

I capture pdfs from Safari and Twitter, and because of that I lost several interesting reseach articles related to my thesis (Edit: The articles are captured but to another database)

Example link is here

Edit: The situtaion is not so dramatic, after further investigation the files were captured, but to the wrong database. The database I planned to share was displayed as to one I am sharing to, instead the files were landing to the database I previously captured. The behaviour was persistent through several attempts, but related to the one specific databe. After playing and restarting the app the behavour came back to normal.

this dont involve any action from developers from now, but I am signalising it ( maybe this report will become obsolete in the light of release of DTTG 3)

sorry to hear that. fyi i tried your example link and it worked ok here. 15.9 mb pdf went into the Global Inbox. i know that does not help you much.

1 Like

When you share and select DTTG you should see the following window:

You can select the database the clip is to end up in by tapping on the currently selected database (Global Inbox in my example).

1 Like

The problem was every time I selected my database “PhD”, but the file was captured to a database “Newsletter” ; I several times checked if I choose the right database “PhD” to capture, but the the files ended in “Newsletter” anyhow.

This behaviour persisted through capturing several files, I didn’t check other databases, after a playing with app it come back to normal

As I wrote, this dont involve any action from developers now, but I am signalising it so maybe in case developers will be working in future on or updating capture mechanims they could check if there is any bug that will be preventing switching the database in some border cases (but again thanks to DTTG 3 this may be complete obsolete remark)

Those additional details / your edit may be useful, thanks :slight_smile: I’ve not experienced this, but @eboehnisch might weigh in on whether it is a bug or not

I haven’t been able to reproduce this issue.

  • Is it consistently reproducible ?
  • What database does the file end up in?

This is not very frequent behaviour, I experienced it first time on my iPhone SE (but I use it only 1 week).
I use DTTG with iPad Pro around a year and I don’t remember such experience.

So this is not a repeatable and the the severity of this is very minor.

The database “PhD” contains grops with pdfs and markdown. files within a DT, but also a folder that is indexed from computer with around 2k pdfs. I don’t know if that matter. The folder was synced a few days ago and the whole database is set to always download.

i will monitor this if this repeat I will write more (So far I am waiting for DTTG3 :slight_smile: )

@aedwards, have you noticed this behavior before? Could you please have a look? Thank you.

1 Like

Thanks for attention about issue!

As I wrote, this behaviour happened only once, a week after installing DTTG 2.7.8 on a new device, this doesn’t need any immediate attention but I will be sensitive to this behaviour in the future if this repeat and report it; there is a big difference between not capturing files at all, and capturing it, one time but not picking a right inbox; It’s much easier to live with the latter

It’s much easier to live with the latter

That’s for sure but I simply shouldn’t happen. If it happens again, please open a support ticket. And if it is reproducible in any way that would be perfect :ok_hand: :slightly_smiling_face:

Within Apple ecosystem there are complex interactions within different parts; A day before I activated Downtime which blocked DTTG and ability to share through sharesheet, but almost instantly I added DTTG to always allowed and then I shared some articles without opening DTTG; I don’t know much about apps API and how they interact with iOS but my guess would be that could be one of the possible causes.

I will be watching if this happening again and trying to reproduce it.