Link to smart group in a note

I use smart groups that, e.g. display certain Labels or Tags. Now I want to link them in a note (e.g., a formatted note) that I use as a template for planning and review. While I can copy the rule link and insert it into the document, clicking that link does nothing. What am I missing? Thx

Is this a long of a global smart group in the sidebar or a local one in a database?

It’s in the sidebar (don’t know what “long of a global smart group” means)

I just tried this using such a link in both rich text and formatted notes. Clicking on it opened a new window showing the smart group as expected. Is the link still valid? Did you click on it in a document or main window?

Just re-inserted the link to be sure. Using the Widescreen view, I click on the link in the document (a formatted note, showing in the preview) - nothing happens

Which version of DEVONthink and macOS do you use? Is DEVONthink’s window in fullscreen mode or not?

3.0.4, 10.15.4, no. Tried in fullscreen mode, but doesn’t work either

A screenshot might be useful, thanks.

What exactly should be shown on the screenshot?

Ideally the complete window or just the complete screen.

This is the formatted note. I also include a picture of the smart rule

I just tried this using a checkbox and the same setup again but still everything’s working as expected, a new window is opened after clicking the link. Do links to the smart rule work in other apps/documents?

This is not working here from the Copy Rule Link option for a global smart group…

[smart group test](x-devonthink-smartrule://F3F1E86C-7E98-489D-9557-31575F37E9F9)

And note the item link shows smartrule though I’m getting the link from a smart group…

Not sure if that’s as intended.


The issues are resolved after a quit and relaunch of DEVONthink, including the link opening a new window for the smart group.


How do you get the “Copy Smart Group Link”? I only get the “Copy Rule Link"

I quit and relaunched DEVONthink.

If you’re able to reproduce this by performing certain actions then additional details would be appreciated, thanks.

Strange. It worked after quit and relaunch. Hope it stays that way … Thanks anyway for going the extra mile with me

Glad to hear it.