Linking to Obsidian URL Not Working

I’ve tried to read some posts, but I guess I’m not doing something right. I copy a link from Obsidian and then put it in a markdown doc in DT like this:


A link it created, but nothing happens when I click on it.



Does the link work in other apps actually?

it works in obsidian, is the syntax correct for DT?

Paste the Obsidian link in Safari’s address bar. Does it work there?

1 Like

no :frowning: doesn’t work in safari or other browsers.

Actually, when I past the raw URL in safari it does work:


but when I try to make it a markup link, it doesn’t work in safari or DT. Is the syntax for my markup link wrong?

a link is created in the preview window, but nothing happens when I click on it.
could there be some block on outgoing links for some reason?

I’m seeing no issue with a Markdown URL, like so…

thanks. did you try to click on “new note”? does obsidian open?
If so, could thre be some permission to open external links or some other reason?
I also get the link, just nothing happens when clicked.

Yes I click the link and the note opens as expected.

If you hover over the link do you see the URL in the Navigation bar over the view/edit pane?

hi, yes i do…

I tried this earlier and had the same problem. But in the interim I closed Obsidian and went out on an errand, and now I have just tried it again, and it is working. So it might be worth just closing one or both programs and trying again.

hmm. seems to be working now that I closed and opened both apps, but not fully.
I have to manually switch to obsidian to see the open file, but when I copy/paste into safari for instance, it opens obsidian on it’s own.
If obsidian is closed however, then it will open obsidian and take me to the right file.
strange. any ideas?

@cgrunenberg would have to comment on this.

The link handling is completely up to the system, DEVONthink doesn’t call Obsidian on its own. Therefore as long as the link is valid and Obsidian installed in /Applications (and ideally only one instance on your computer), everything should be fine.

thanks. not sure why then it doesn’t work, but I’ll keep trying things.