Links don't survive cut and paste in RTFs

I notice that, in .rtf files, if I cut some text, part of which includes a link (either DT3 link or web link), the link does not get pasted to its paste destination.

Instead, I have to copy the link, put it somewhere temporarily, paste the text and then re-link the relevant text.

Someone else appeared to overcome this by enabling the “smart links” preference, but I find that toggling the “smart links” or “data detectors” preferences either way makes no difference to this.

edit: I don’t think that forum link was my issue

  • Are you occurring from or pasting into RTF files?

  • In DEVONthink or other application?

“occurring from” ? I guess you meant copying from?

In any case, I’m copying and pasting from and to RTFs in DT3.

“occurring from” ? I guess you meant copying from?

Welcome to iOS autocorrect. Ugh!

I’m not seeing any issue here.

What version of DEVONthink and macOS are you running?
Screen captures could be helpful.

Is this a Wiki link, an item link or a different link?

Yes, autocorrect can be so annoying, just like the red king’s pencil in Through the Looking Glass.

Anyway, I find this happens on my iMac running macOS 10.15.7 “Catalina”. But now I discover that it also happens in TextEdit, so it’s not DT3.

I just synced an .rtf (where this happened) to DT3 on my other Mac — a MacBook Pro running macOS 11.0.1 “Big Sur” and it does not happen on that machine; there, links survive the paste. So maybe it’s the macOS version that makes the difference, though having said that I get the impression that this shouldn’t happen on Catalina.

It’s not a Wiki link. It’s just where you select some text, and choose “Add Link…” from the right-click contextual menu, enter a link (either a web link or a DT3 item link). If I copy and paste that text, the pasted text doesn’t contain the link.

And where do you actually paste it? Did you definitely add the link on your own or could it be an automatic link added by data detectors (see Preferences > Editing)?

It happens when I paste it anywhere - to the same document for instance.

And yes, it’s when I add a link myself, manually, not a link that’s created automatically.

Just tried this but works as expected. A screenshot of the selection before copying and a screenshot after pasting might be useful.

Here are some screenshots that show what goes wrong on the iMac:

I suppose it’s just possible that it could be a combination of the Catalina macOS and this iMac: I’ve noticed that some other software had glitches (which I thought were bugs in the software) but they disappeared on the MacBook Pro when I upgraded it to Big Sur.

I’m not overly keen on upgrading the iMac to Big Sur though - I don’t like the layout with the toolbars (though I think DT3 did a good plastic surgery job with that). But it’s still hard sometimes with Big Sur to tell if a window’s in focus. But, oh well, perhaps I could try it, unless someone sees an alternative explanation.

try different fonts? Same thing happen in OSX’s TextEdit app?

For lots of reasons, Big Sur has been an improvement for me fixing a few things (outside of DEVONthink). Taking no notice of the Tool bars, actually, here. Yes, see lots of chat about people unhappy with toolbars, but I guess they have time to chat about it. :wink:

1 Like

Aah I’ve discovered what it is! I’m using some software called “Copy Em” and it was set to “plain text mode” and somehow it was taking over the clipboard and making everything paste without links. Turning off its “plain text mode” enables links to survive again.

My profound apologies for implicating DT3 !