links in mardown

When I paste a Devothink link to a document in Markdown and hit enter, the link turns to blue and I can click the link and open the document. But I always have to hit enter to make it active. I tried to use a proper MD syntax but the behavior remains the same: I have to hit enter after the link. There is a way to have the link active all the time?

Do you use data detectors (see Preferences > Editing)? Markdown is a plain format and there shouldn’t be any clickable links usually while editing.

Yes, I do use data detectors. You are right, I should not see a blue link in markdown. I will send a screen grab where you can see the blue link in a simple text file.

Strange behavior, no?
blue link in a MD text.tiff (194 KB)

Data detectors can be disabled in Preferences > Editing but I’m not sure whether they should be always disabled in case of Markdown. Might be useful sometimes nonetheless.