Links in PDFs not showing in Incoming Links of linked PDF


I’m trying to link references (in journal article PDFs) to their DEVONthink documents (also PDFs), however when I go to Incoming Links in the linked document, the PDF that I annotated does not show up.

Here are two screenshots to illustrate:

So here, I’ve selected text in the document Rajan, H. (2018). and used Link To in the right-click menu to add a link to another document Leung, L. C. (2011).. Both these files are PDFs and are in the Inbox of the database Research.

However, when I go to Incoming Links in the document Leung, L. C. (2011)., there’s nothing there. I expect to see an incoming link from Rajan, H. (2018).

I’ve tried linking both using the Link To menu option, as well as using the PDF annotation Link tool to manually add the item link, but same results: The link shows up in Outgoing Links of the PDF where the link is created, but not in Incoming Links of the PDF that was linked to.

This is the first time I’m trying this, so I’m not sure if it had worked before, but I assumed that this should be expected behaviour, unless I’m mistaken?

The reason I’m doing this is so that I can build and see where journal articles I have are cited in my database through Incoming Links.

Appreciate any advice, thanks, and please let me know if I can provide any more information!

Does a rebuild of the database (see File menu) fix this?

Hi @cgrunenberg, thanks for getting back. No, a rebuild doesn’t result in a permanent fix. I should have mentioned that before writing my post, I’d done:

  • Verify & Repair Database
  • Check File Integrity
  • Optimize Database
  • Rebuild Database

And I just did a rebuild again after reading your message. What happens seems to be inconsistent.

For example, when I did a rebuild previously, links that are already existing then show up in Incoming Links but then, they disappear again at some point, not sure why, maybe close and reopen database but cannot be certain. And if I try to link again, they don’t show up again, unless I rebuild the database again.

And then below, something completely different happened when I tried to replicate the above issue after just rebuilding:

Creating a link in Scheff, T. J. (2003). to Dickerson, S. S. et al.

Scheff, T. J. (2003). doesn’t show up in Incoming Links for Dickerson, S. S. et al.

I then do a new rebuild of the database again.

Scheff, T. J. (2003). now does shows up in Incoming Links for Dickerson, S. S. et al.

But then if I try again with two different PDFs, the same issue happens again.

Creating a link in Thomson, R. G. (2000). to Bishop, C. (2004).

Thomson, R. G. (2000). doesn’t show up in Incoming Links for Bishop, C. (2004).

But the links mentioned in my previous message seem to be showing up i.e. Rajan, H. (2018). in Incoming Links for Leung, L. C. (2011). and persistent i.e. I opened and closed the database, and I shutdown and restarted DEVONthink, and still there.

I’m on macOS Ventura 13.5 and DEVONthink 3.9.2, if that helps.

Are you seeing the disappearing links in another database?

Hi @BLUEFROG, interestingly, no.

I opened another existing database I have, reference, downloaded and imported fresh copies of two journal articles and did the same thing, and it worked and persisted after closing and re-opening DEVONthink as well.

Creating a link in Antagonism and Relational Aesthetics to Blogging as art art as research.

Blogging as art art as research shows up in Incoming Links in Antagonism and Relational Aesthetics.

Also interestingly, I’ve started to notice that when I use Clip to DEVONthink in my browser to clip to the (what I now suspect to be problematic) database research, even though I definitely select the format of Markdown, sometimes it’s clipped as a web location instead. I couldn’t reproduce it unfortunately, it seems to be random.

What would be the right thing to do next? Do I simply create a new database and simply move all files from research to the new database? If so, is there a way I can do so to a new database also named research.dtBase2? Do I rename the old research.dtBase2 to something else before I create a new research.dtBase2?

Or something else? Thanks again!

Actually, it just happened, the clipping issue. I just tried to clip a news article to research >Inbox and I definitely selected Markdown for the format, and didn’t change anything else, and it got clipped as a Web internet location.

Sharing in case this is of interest for data in general.

I’m using Clip to DEVONthink 1.5.2 on Brave 1.56.14 Chromium: 115.0.5790.114 (Official Build) (arm64).

This has been discussed before, also recently. The problem could be that a lot of the site is generated dynamically with JavaScript.

You could load the relevant page (after confirming the Guardian’s nag stuff) in DT’s browser and then convert that to MD. Not ideal, I know.

Hi @chrillek, thanks for that information, I didn’t know that and I’m good with that workaround for the issue of Web location being clipped instead of Markdown as I’m familiar with it and use it on occasion.

My approach with any page I find on the internet that I want to keep is to use the browser to print to PDF. That way I “freeze” the content in the state that I found it, and I have a permanent copy in case the web page changes, or disappears. Print to PDF on Safari normally has the URL at the foot of each printed page, and the print dialog on my system allows me to print the PDF directly to DEVONthink. I find this system suits me better than using the web clipper.

Is there anything special about one of the databases? E.g. is one synchronized, the other not? Or one processed by smart rules? So far I couldn’t reproduce the issue.

Hmmm, not that I can think of.

  • They are both synchronised.
  • I use them similarly, both on macOS and iOS on DT2G.
  • They contain similar kinds of documents.
  • They are not password protected.
  • They are not encrypted databases.

The only thing that I can think of is that I remember renaming research from reference, both in DT directly in Database Properties. I can’t remember but I may have done so as well as in Finder i.e. renaming the *.dtBase2 file directly when the database was closed? I think I did, actually, because what I did was the original research was named reference and I split the contents of the old reference into two databases, a newly created reference and the old reference renamed as research. I hope that made sense.

This was more than a month back, I think, I didn’t keep track of the date. I didn’t start experiencing problems until this week, however this was also the first time I tried linking in PDFs, so not a good measure.

Oh and the only other thing that happened recently is that I bought a new MacBook Pro a few weeks back and synced all my databases on here. My old MacBook Air hasn’t been touched in a few weeks. I made the renaming changes on my MacBook Air.

But that’s all I can think of but please do let me know if there’s anything else I can check. I’m not the most fluent with DT so there could have been something I’ve missed.

Here are each of the databases’ properties, in case there’s anything there that may help:

Renaming the database(s) shouldn’t have any bearing on the issue you’re reporting.

  • What sync method are you using?
  • Are there any other changes that have disappeared?

I’m wondering if there’s an issue with your sync data.

iCloud (CloudKit) and I’ve only ever used this method since I started using DT.

Oh dear, I hope not, that would be exceedingly frustrating to not know what I’ve lost. But in answer, not that I’ve noticed before now.

Unless this counts: Sometimes when I copy and paste a Markdown document (I do this when annotating because it saves time to not need to populate same tags and data each time), and I edit the contents of the Markdown, even if I press Cmd+S the changes will not save. I’ll click out of the document and click back to find that it’s reverted to its original contents. What I think I’ve noticed is that sync seems to start shortly after, and after that, changes will stick. I only do annotations in research though, so no data on this happening in other databases, and it’s also inconsistent.

If this turns out to be relevant, I’ll try to replicate tomorrow.

That is definitely not normal and sounds like it could be a sync issue to me.

  • What other devices are on and syncing together?
  • What is your sync interval set to in DEVONthink’s Preferences > Sync?

Please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - - thanks! Maybe there’s a hint in the logs.

Other devices syncing are:

  • DEVONthink To Go 3.7.3 on iOS 16.6 (iPhone) and iOS 16.5.1(c) (iPad), I sync to and from the iPhone more frequently, only sync to iPad occasionally
  • DEVONthink 3.9.1 on macOS Monterey 12.6.5 (MacBook Air), I no longer use this though

On my primary device, it’s every five minutes. I don’t use my MacBook Air anymore, but it used to be set at five minutes too.

Interestingly, I just noticed something: On both my iPhone and iPad the schedule is set to automatic, and Keep all is set to the max of the slider, but:

  • On the iPhone, Conflicts was set to Newest, whereas,
  • On the iPad, Conflicts was set to Duplicate.

Not sure if that’s got any relevance, but sharing in case. I didn’t realise there was a difference in my settings until looking now.


Are you seeing any duplicated files?

I created a Smart Group to check for this across all databases and turns out, yes, but only a handful, and only the ones from databases research and reference might be of interest, the rest from archive are deliberate duplicates:

However, these may also have been caused by me “double clipping” i.e. I forget I’d already clipped something, stumble across it again, so clip it again. The dates suggest this may have happened for these two.

I missed your earlier question about Smart Rules @cgrunenberg, no I only have the default Smart Rules that came with my DT installation, pretty sure. Here is a screenshot.

The two reminders are for documents in the personal database, so not research.

Hi @cgrunenberg and @BLUEFROG, just checking in on this issue, specifically on any immediate next steps I can take? Many thanks!