Login issue with the server

Hi there,
I have a little problem logging in to the server. But not generally, but only in certain scenarios. So I cannot log in, when I see the main DT Server screen:

I can, however, log in using this green “Authenticate with HTTP” link, but only in safari, not in chrome. In chrome I cannot log in at all.
In curio, I can also reach the DEVONthink server via Sleuth.
And also on my mobile I can log into the DT server.

What could be the issue? Why can’t I log in using the normal splash screen?

Did you try to login on the Mac or e.g. from a PC? Which version of Chrome do you use? Any third-party extensions?


I tried on a mac. localhost:41111. Also with the IP of my LAN and with the port.
I have extensions, but I deactivated them all.
Also in Safari. The same. I can log in on Safari with the link, the rest does not work.

Are JavaScript and cookies enabled in Safari’s preferences?

Everything enabled. On a windows pc in the same network I could not log in either, but there it was Bitdefender, that blocked the login. On my Mac I also run Bitdefender, but I did not get any message, so I assumed, that it did not block anything there… or do you think, Bitdefender could be the culprit?
I really don’t understand, that I can access the splash screen from everywhere, but only login via the http link in Safari and in Curio… strange thing, but I am sure, we will find the answer :grin:

Are you using a self-signed certificate called DEVONthink Server? It’s in Preferences > Server > General.

No. Not yet.

What have you set there? A screencap may be helpful.

Looks like this:

I tried using the certificate, now it looks like this:

Chrome still does not work, but Safari and Firefox. We are coming closer :grinning:

If you don’t have a certificate specified, you should only be able to use the http transport (ie. the green link in the browser), no matter the browser.

Ok… seems like I am slowly getting it…

Now it runs like this:

So Curio can use the server via the http port 41111, and the rest runs on https port 56613. Safari and Firefox work as expected, only chrome does not.
I think, it is okay like this…

Thanks a lot :+1:

You’re welcome. Note: browsers may complain about the danger of the certificate. Generally, you should obviously pay attention to such warnings, but when you know it’s you and your server, you push on through. :slight_smile:

Try to change the port number to see if Chrome allows some other port number or range in case this specific one is blocked inside Chrome of some reason or two…

I tried the standard https port, 443, for testing. Also no success…
My chrome does not like DEVONthink :sleepy:

I started the server and I could see the login screen on port 5555 with both Safari Version 12.1 (14607. (latest) and Chrome Version 74.0.3729.131 (Official Build) (64-bit) (latest). Now I was able to add in an account but I could not set a password and if empty it still asked for password so https didn’t work. http on Safari and Chrome worked, though. So I suspect we need more info how to really use the https connections as those require a key for TSL connections.

https requires a password and also a single-word username, even if a concatenated name, e.g. johnappleseed is acceptable; john appleseed is not.

Use the DEVONthink cert.

and try setting port 50000 or let DT choose one for you.

1 Like

Thanks, before I was unable to change the password or edit it, now after restarting I could change it but I can’t still log in via the https URL. Hmm, need to look at logs later today to see what is going one. This is on the same device, btw, not with another computer, MacOSX 10.14.4.

Did your username or password contain spaces?

I need to retest, but no I never used spaces and odd characters in passwords (old unix hacker…).