Lost ability to send pdf to DT3 after Catalina upgrade

Before I upgraded to Catalina, I could open a PDF in Preview and select “Print”. At the bottom left of the print dialog box, is the “PDF” button. On clicking that, the dropdown included the option to “Save PDF to DT3”. That option remains, but if I try to use it, I get a message that says “Error while printing” every time. How can I fix this?

In which application do you actually try this? You remove the PDF service from ~/Library/PDF Services and install it again via DEVONthink 3 > Install Add-ons. However, in the end it’s just an alias of the application. The printing is handled by the source application and macOS.

I tried this in the Preview application. I have installed PDF services via the DT3 add-ons, and still get the same message of an error.

Does it work after enabling full disk access for DEVONthink 3, see System Preferences > Security?

Already tried that. DT3 does have full disk access.

Does it work in other applications, e.g. TextEdit, Mail or Safari?

yes. Works in Mail and Safari.

In that case it’s probably an issue of Preview. DEVONthink’s sharing extension (if enabled) might be a good alternative (see System Preferences > Extensions and File menu in Preview).

That works. I would think that others would have noted this using Preview, or am I the only one who sends things from Preview to DT3 this way? It is a fresh install of macOS15, so would think Preview is up to date.

Why are you printing a PDF to DEVONthink from within Preview when you can easily add the PDF to DEVONthink directly?

Good question. Obviously there are several ways to accomplish the same thing. I’m not “printing” anything, just using the print dialog box to get to the “move the DT3” functionality. Now that I see the share option, I can do the same thing. Old habits die hard. I must have had a good reason at some point!

You can also just add the PDFs into DEVONthink and view them directly! :slight_smile:

Actually it works as expected over here. Are you able to print PDFs to other apps from Preview?

I am running Catalina (currently MacOS 10.15.3 beta 3) and use Print to PDF to add documents to DT3 from Preview as well as a variety of other apps all the time. In fact it is my “go to” solution any time I have a problem getting a document into DT3 from any app.

I use the print to PDF option in the print dialog and send the file to my ‘devonTHINK Import’ folder. Then Hazel runs an AppleScript to move the file to DT.

Welcome @DeadSalmon

Note you can do this in DEVONthink with a smart rule now instead of using the Hazel rule.
You can even continue using the “devonTHINK Import” folder.

  • Note this targets the devonTHINK Import folder I indexed into my Global Inbox.

  • It moves the file into the database, thus removing it from the Finder folder since it imports the file.

  • Then it moves the file to another database.

  • The Play Sound is optional but can be useful when debugging.

I had the same issue as the original inquiry. In Preview, print to DT3 causes an error message. I miss that capability in Catalina. This still works in Mail, however, and is my preferred method for saving an email to DT3. If I save the email message directly, years later when I look at the file, components of the original email message are missing. Saving as PDF circumvents that problem.

And do you have Full Disk Access enabled for DEVONthink?

Yes. Full disk access is enabled

Full Disk Access is enabled, yes.