Mac to WebDAV to iPhone App - Not working since upgrade to 3.0

I’ve read through the forums and can’t find the answer I’m looking for, so I hope this is not a duplicate question.

I have my desktop version of DTP 3.x syncing to a WebDAV folder on an internet-accessible mac server. It’s syncing two databases and the global inbox and totals around 40gigs of data. There are zero errors syncing to the server and everything is in “the cloud” on my server.

On the iPhone, I add the correct sync store, user name, and login and encryption key. So in theory, everything should work. But not only does the inbox not sync (which is small and should be the easiest thing to sync), but the other two databases don’t show up as “remote” options to sync.

When I was using desktop version 2.5, this all worked. So it’s not like I don’t know how it should work.

I’ve tried deleting the app on the iPhone and setting everything up from scratch. I even deleted the old sync store and created a new one and uploaded everything again - but no difference.

I feel like either something is really broken and not documented, or I’m really a lot stupider than I realized.

Any help or advice is appreciated.

For clarification: is this server available in a LAN (that you control) or only over the internet?

Both should work I guess, but it’s usually easier to troubleshoot on your LAN and if possible within the same subnet.

It’s over the internet but yes under my control. FQDN, and as I mentioned there is no issue getting the desktop to sync to it, I just can’t get the iPhone to sync back. But the phone itself has no issues logging in and there are no errors generated.

It’s as if the database syncing from the desktop is not compatible with the iPhone app.

Do any of these issues apply?

I.e. do you use spaces, and are those URL-encoded? Have you specified the correct port?

The syntax of URL to WebDAV using HTTPS should be:

No sorry, none of this applies. And since this was all working before the update to iPhone 3.x version, I am becoming more and more convinced there is a bug here of some kind. I’m going to open a support ticket later today.

WebDAV Sync works fine here with two Macs, one iPhone and one iPad. All witch the most recent versions of OS and DT(TG). The Webdav server is provided by Deutsche Telekom.

Be careful with Upper/Lower case in sync database names.

I had same issue to discover that in my iMAC I was set “Store” and “store” in one of my iThings (found it looking inside my webdav sync directory from NAS admin account).