MacOS Monterey Support

Worked for me also this morning after the 12.0.1 Monterey release and a restart

DEVONthink_BigSur.mailbundle (October 7, 2021 at 6:38 AM) does not play well with Mail 15.0 running under macOS 12.0.1 on a new 16" MacBook Pro M1 Max.

Well, for starters damn, I’d like one of those (well, the 14” version, actually - just in case anybody decides to send me one); then back to the point: I see two possibilitiesm

a) this is specific to the M1 Mac - do you have Rosetta installed (this is not to suggest that is the solution, it’s just an idea)
b) when you go to Install Add-ons is there any suggestion that the Mail plugin could be updated?

It might be worth deleting the plug-in bundle and reinstalling it. And it might be helpful to expand on what you actually mean by “doesn’t play well”.

Sorry about the lack of specifics in my post and the cryptic doesn’t play well statement. I should have waited until today when I have more time.

I used Migration Assistant to copy my files and settings from a mid-2018 MacBook Pro to my new 16" MacBook Pro M1 Max. I usually do a clean install when setting up a new machine, but my installation was running so well I decided to do it the easy way.

I noticed early on that the DEVONthink Mail Plug-in was not working, so I activated it by adding the necessary checkmark in Mail Preferences. NOTE: the computer was running macOS 12.0 at this point and the version of DEVONthink_BigSur.mailbundle was not the latest. The plug-in functioned as expected at this point.

I upgraded to macOS 12.0.1, after which I received a message stating Incompatible Plug-ins Disabled. I opened preferences, rechecked the Plug-in only to receive the message again.


I then searched my drive for and found a newer version of DEVONthink_BigSur.mailbundle dated October 7, 2021 at 6:38 AM. I copied this to the former location of the older version. I then checked the new Plug-in in Mail Preferences, Mail closed and reopened with the same warning.


To respond to your questions:

  • Yes, Rosetta is installed. I had no other choice if I wanted to run some necessary apps.

  • I didn’t think of checking Install Add-Ons at the time, but Apple Mail Plugin is unchecked and grayed out.

  • I tried deleting and reinstalling. Clicking on Install Add-Ons brings me to the Handbooks and Extras web page that lists no Apple Mail Plugins.

I could be wrong, but It appears to me that macOS 12.0.1 broke the Mail Plug-in’s functionality.

Works for me

1 Like

My Macbook which was updated to Monterey has a working Mail plugin. On my desktop installed a clean Monterey. After installation of DEVONthink I was unable to activate the Mail plugin. The MacBook Air is M1 and the desktop is Intel based.

Did you allow access per the prompt?

RE: the email plugin in Monterey, try this if enabling the plugin in Mail isn’t working…

  1. Quit Mail.
  2. Quit DEVONthink 3.
  3. Enable Full disk access and all Automation requests for DEVONthink 3 in System Preferences > Security & Privacy > Privacy.
  4. In the Finder, hold the Option key and choose Go > Library.
  5. Go into the Mail/Bundles folder and delete the DEVONthink.mailbundle.
  6. Relaunch DEVONthink 3 and install the Mail plugin from DEVONthink 3 > Install Add-Ons.
  7. Relaunch Mail and enable the plugin via Apple Mail’s Preferences > General > Manage Plug-ins.

You obviously have the magic touch, Jim. It seems to be working fine now.

Unless you have a different explanation I’m thinking my original copy of DEVONthink.mailbundle was corrupt.

Thank you…

Thank you! :slight_smile:

1 Like

Migration Assistant can sometimes cause permissions issues (a known and long-standing thing in macOS/OS X). I’d suspect that could have been the issue. But a fresh install of the plugin should definitely clear that up.

You’re welcome, to @wernervp as well :slight_smile:

1 Like

I have a new MacBook Pro 14 M1 Pro with the latest version of Monterey (12.0.1) and the latest version of DT3. Followed your instructions to the letter and doesn’t work for me. The plugin that gets installed says ‘Devonthink_BigSur.Mailbundle’. I’ve tried several times. Same result each time. I even rebooted the system several time.

Same here; works even so (Intel iMac, however, no newfangled M1 :expressionless: I tell myself I’m waiting for the M2Z)

What result? Does the plugin actually not work, and if so, what happens?

  • In the Finder, press Shift-Command-G and paste /Library/Mail.
    • If the directory exists, check if our plugin is installed in the Bundles folder.
      • If it’s there, delete it then reinstall it from DEVONthink.

When I upgraded to Mac OS Monterey it turned off Mail’s ability to reveal how many emails were unread in my inbox. I tried everywhere to find how to turn that back on & then I stumbled on “Notifications & Focus” in the “System Preferences”. Choosing Mail on the left & turning “Badge app icon” on brought it back. In case anyone has the same problem.

Welcome @lpagross

Thanks for sharing the pointer with the rest of the class :slight_smile:

Thank you! Worked for me as described. (MBP M1, MacOS 12.0.1, Mail 15.0, DT 3.8)

Welcome @mmore

Fantastic! You’re welcome and thanks for sharing your experience. :slight_smile:

Monterey 12.1 seems to have disabled the DEVONthink Mail extension for me. I’m in Mail 15.0 now.

lots of posts on this, e.g. today’s MacOS 12.1 Update > Devon Plug-In not working - #3 by Blanc