MacOS Monterey Support

RE: the email plugin in Monterey, try this if enabling the plugin in Mail isn’t working…

  1. Quit Mail.
  2. Quit DEVONthink 3.
  3. Enable Full disk access and all Automation requests for DEVONthink 3 in System Preferences > Security & Privacy > Privacy.
  4. In the Finder, hold the Option key and choose Go > Library.
  5. Go into the Mail/Bundles folder and delete the DEVONthink.mailbundle.
  6. Relaunch DEVONthink 3 and install the Mail plugin from DEVONthink 3 > Install Add-Ons.
  7. Relaunch Mail and enable the plugin via Apple Mail’s Preferences > General > Manage Plug-ins.

You obviously have the magic touch, Jim. It seems to be working fine now.

Unless you have a different explanation I’m thinking my original copy of DEVONthink.mailbundle was corrupt.

Thank you…

Thank you! :slight_smile:

1 Like

Migration Assistant can sometimes cause permissions issues (a known and long-standing thing in macOS/OS X). I’d suspect that could have been the issue. But a fresh install of the plugin should definitely clear that up.

You’re welcome, to @wernervp as well :slight_smile:

1 Like

I have a new MacBook Pro 14 M1 Pro with the latest version of Monterey (12.0.1) and the latest version of DT3. Followed your instructions to the letter and doesn’t work for me. The plugin that gets installed says ‘Devonthink_BigSur.Mailbundle’. I’ve tried several times. Same result each time. I even rebooted the system several time.

Same here; works even so (Intel iMac, however, no newfangled M1 :expressionless: I tell myself I’m waiting for the M2Z)

What result? Does the plugin actually not work, and if so, what happens?

  • In the Finder, press Shift-Command-G and paste /Library/Mail.
    • If the directory exists, check if our plugin is installed in the Bundles folder.
      • If it’s there, delete it then reinstall it from DEVONthink.

When I upgraded to Mac OS Monterey it turned off Mail’s ability to reveal how many emails were unread in my inbox. I tried everywhere to find how to turn that back on & then I stumbled on “Notifications & Focus” in the “System Preferences”. Choosing Mail on the left & turning “Badge app icon” on brought it back. In case anyone has the same problem.

Welcome @lpagross

Thanks for sharing the pointer with the rest of the class :slight_smile:

Thank you! Worked for me as described. (MBP M1, MacOS 12.0.1, Mail 15.0, DT 3.8)

Welcome @mmore

Fantastic! You’re welcome and thanks for sharing your experience. :slight_smile:

Monterey 12.1 seems to have disabled the DEVONthink Mail extension for me. I’m in Mail 15.0 now.

lots of posts on this, e.g. today’s MacOS 12.1 Update > Devon Plug-In not working - #3 by Blanc