MacOS Monterey Support

What do I look at to determine the plug-in version? What I can tell you is most of the files in that directory are time-stamped created Tuesday, August 31, 2021 at 10:13 AM

Sounds like version 4.0.3. Did you check whether a new plug-in is available via DEVONthink 3 > Install Add-ons? Maybe after restarting the app?

Apple Mail plug in greyed out. See attached screen shot.

Even after restarting the app and trying again? Is your computer online as the latest version is only available online & downloaded?

The latest version of DevonThink Pro 3.8

Screen Shot 2021-10-18 at 8.51.51 AM

Latest macOS

Screen Shot 2021-10-18 at 8.53.30 AM

Screenshot from DevonThink Install Add-On screen.

And finally, a screenshot of the error served up when restarting Apple Mail after enabling plug-in.

I have restarted mail, DEVONthink, and even rebooted MacOS multiple times.

I have a similar issue. Current version of DT Pro and 4.0.4 mail plugin seems to be installed. But I don’t even get an error message that something was deactivated when I start Mail. Only an empty window when I check installed extensions…
Anyone got an idea about this? Thanks a lot in advance!

I see the same behavior, same error/dialog windows as Gerry does.

OK, so now I got a little further. I missed the part of activating at as a plugin not as an extension (First tab of the settings dialogue). Now 4.0.4 is accepted by Mail and I don’t get any error message when starting Mail. But I don’t see any functionality… so no button “transfer to DT” or similar… Am I missing something here?

In my version of MacOS and Mail (older than yours and not beta), there is no “button” to transfer to DEVONthink. With a mail message selected, Mail Menu: Message → Add to DEVONthink 3 with a short cut key reminder shown. Inside DEVONthink there is a way to either “Archive Mailbox” or “Import”. See the DEVONthink Handbook (or Help) for details.

Maybe MacOS beta not developed sufficiently or something …

1 Like

Great, that helps a lot. Thanks!

Is version 4.0.4 installed and enabled in Mail’s preferences?

I tried to go through the steps of installing the plug-in in DevonThink then enabling the plug-in in Apple Mail and voila today it worked. I don’t know what made it work but a new version of macOS beta came out last night which I installed. It didn’t work immediately after but it did this morning. Here are my latest versions.

macOS Monterey Version 12.0.1 (21A558)

Apple Mail Version 15.0 (3693.

DEVONthink 3 Pro Version 3.8

Plug-in I can’t see the version anymore but is odd that the mail plug-in is called DEVONthink_BigSur.mailbundle? I suspect it’s a simple naming issue not version. The mailbundle files all have a create date of October 8, 2021 6:15am. Which is different. The install apparently worked this time.

I didn’t observe any installation status or progress indication when I installed the plug-in. It would be helpful to see one Not sure if that’s a bug or enhancement request. Long story but it works now. I hope this helps someone out there.

It’s the plug-in for Big Sur & later.

That’s version 4.0.4.

Worked for me also this morning after the 12.0.1 Monterey release and a restart

DEVONthink_BigSur.mailbundle (October 7, 2021 at 6:38 AM) does not play well with Mail 15.0 running under macOS 12.0.1 on a new 16" MacBook Pro M1 Max.

Well, for starters damn, I’d like one of those (well, the 14” version, actually - just in case anybody decides to send me one); then back to the point: I see two possibilitiesm

a) this is specific to the M1 Mac - do you have Rosetta installed (this is not to suggest that is the solution, it’s just an idea)
b) when you go to Install Add-ons is there any suggestion that the Mail plugin could be updated?

It might be worth deleting the plug-in bundle and reinstalling it. And it might be helpful to expand on what you actually mean by “doesn’t play well”.

Sorry about the lack of specifics in my post and the cryptic doesn’t play well statement. I should have waited until today when I have more time.

I used Migration Assistant to copy my files and settings from a mid-2018 MacBook Pro to my new 16" MacBook Pro M1 Max. I usually do a clean install when setting up a new machine, but my installation was running so well I decided to do it the easy way.

I noticed early on that the DEVONthink Mail Plug-in was not working, so I activated it by adding the necessary checkmark in Mail Preferences. NOTE: the computer was running macOS 12.0 at this point and the version of DEVONthink_BigSur.mailbundle was not the latest. The plug-in functioned as expected at this point.

I upgraded to macOS 12.0.1, after which I received a message stating Incompatible Plug-ins Disabled. I opened preferences, rechecked the Plug-in only to receive the message again.


I then searched my drive for and found a newer version of DEVONthink_BigSur.mailbundle dated October 7, 2021 at 6:38 AM. I copied this to the former location of the older version. I then checked the new Plug-in in Mail Preferences, Mail closed and reopened with the same warning.


To respond to your questions:

  • Yes, Rosetta is installed. I had no other choice if I wanted to run some necessary apps.

  • I didn’t think of checking Install Add-Ons at the time, but Apple Mail Plugin is unchecked and grayed out.

  • I tried deleting and reinstalling. Clicking on Install Add-Ons brings me to the Handbooks and Extras web page that lists no Apple Mail Plugins.

I could be wrong, but It appears to me that macOS 12.0.1 broke the Mail Plug-in’s functionality.

Works for me

1 Like

My Macbook which was updated to Monterey has a working Mail plugin. On my desktop installed a clean Monterey. After installation of DEVONthink I was unable to activate the Mail plugin. The MacBook Air is M1 and the desktop is Intel based.

Did you allow access per the prompt?